|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21644 PHP compile fails with PDFLIB
Submitted: 2003-01-14 18:48 UTC Modified: 2003-01-18 18:44 UTC
From: ekonopka at konopka dot org Assigned:
Status: Closed Package: PDF related
PHP Version: 4.3.0 OS: Slackware Linux 2.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: ekonopka at konopka dot org
New email:
PHP Version: OS:


 [2003-01-14 18:48 UTC] ekonopka at konopka dot org
Using PHP 4.3.0 and PDFLIB 4.0.3 with the PHP 4.3.0 patch (pdf.c) I can't compile PHP.  I build PDFLIB from source, copied the pdf.c and config.php-406+.m4 to the php-4.3.0/ext/pdf directory (the config to config.m4).

Configured PHP with:
./configure --prefix=/opt/php --exec-prefix=/opt/php --with-mysql --with-apache=../apache_1.3.27 --with-pdflib

Since PDFLIB base directory is /usr/local I didn't specify a PDFLIB path.

It configures fine, but during the make I get (last few lines of output):

ext/mysql/libmysql/my_tempnam.o: In function `my_tempnam':
/root/source/php-4.3.0/ext/mysql/libmysql/my_tempnam.c:103: the use of `tempnam' is dangerous, better use `mkstemp'
main/internal_functions_cli.o: In function `php_startup_internal_extensions':
/root/source/php-4.3.0/main/internal_functions_cli.c:69: undefined reference to `pdf_module_entry'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

If you need more output, let me know.  I have never successfully built PHP with PDFLIB on all sorts of different platforms.  I'm surprised other people have been able to.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-14 19:28 UTC]
Try WITHOUT the patch.

 [2003-01-14 20:00 UTC] ekonopka at konopka dot org
Same error messages.
 [2003-01-15 03:26 UTC]
Did you try with clean, unmodified PHP 4.3.0 sources?
And try adding the path, use --with-pdflib=/usr/local

 [2003-01-18 18:44 UTC] ekonopka at konopka dot org
Seemed to do it.  I'm surprised it worked, but it did.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu May 30 22:01:29 2024 UTC