php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21587 ob_gzhandler sending out empty pages
Submitted: 2003-01-11 14:26 UTC Modified: 2003-01-12 10:57 UTC
From: epoc_32 at yahoo dot co dot ukXXX Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 4.3.0 OS: FreeBSD 4.6
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: epoc_32 at yahoo dot co dot ukXXX
New email:
PHP Version: OS:

 

 [2003-01-11 14:26 UTC] epoc_32 at yahoo dot co dot ukXXX
I have an obsolete PDA browser which doesn't support gz compressed pages but sends out the following (unnecessary) header in it's HTTP requests:

"Accept-Encoding: "

using ob_start("ob_gzhandler"); leads to the browser receiving empty pages.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-11 23:12 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 [2003-01-12 10:06 UTC] epoc_32 at yahoo dot co dot ukXXX
I can't upgrade PHP on my host's server but I did get someone to test with PHP 4.3.0 on Linux and the problem was fixed, thanks.
 [2003-01-12 10:57 UTC] moriyoshi@php.net
If you want to let PHP automatically choose an appropreate encoding scheme
by Accept-Encoding header that is sent by clients,
try zlib.output_compression directive instead of using ob_* stuff.

Not a php developer issue though.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu May 28 07:01:25 2020 UTC