php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21553 script/process keeps running and then times out
Submitted: 2003-01-09 12:30 UTC Modified: 2003-01-09 15:56 UTC
From: tpage at hiwaay dot net Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.2.3 OS: w2k
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tpage at hiwaay dot net
New email:
PHP Version: OS:

 

 [2003-01-09 12:30 UTC] tpage at hiwaay dot net
Have php loaded on IIS 5 as a CGI. When I go the the php 
page,via web browser, the php.exe process will not end. 
Though the page is loaded the process keeps running unit I 
kill the process or it times out.

The test script that I did was a simple:
<?
echo "wahtever";
?> 

but it will not end!!!

I even tried to adding each of the following:
exit(); 
exit;
die();
die;

still no luck!

thanks 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-09 15:56 UTC] derick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 [2003-01-16 15:40 UTC] gregory_pearson at adp dot com
We have a similar problem with the CGI module under IIS 5.0, Win2K, SP2, PHP 4.2.3. Although we do not experience the problem with simple scripts like the example here, we do get what we call the "spinning globe" with a few of our more complex scripts that call themselves, use DOM, access Oracle databases, etc.

The problem existed in 4.0.6 and we thought migrating to 4.2.3 would cure it, but it did not. Interesting thing is that we were able to solve it in one app. by rewriting the more complex code that relied heavily on DB access, but still do not have a clue why the problem went away.

Responses from other users on the list ranged from flawless execution under IIS 4.0 to performance problems (inconsistent execution times) under IIS 5.0.

Looks like the only answer may be migrating to 4.3.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 15:01:28 2024 UTC