php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21501 ISAPI Troubles
Submitted: 2003-01-07 18:45 UTC Modified: 2003-01-08 04:58 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: support at rhsoft dot net Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 4.3.0 OS: Windows 2K/2Kserver/XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: support at rhsoft dot net
New email:
PHP Version: OS:

 

 [2003-01-07 18:45 UTC] support at rhsoft dot net
I found some problems with the ISAPI module under windows with differnet webservers

First: mail() dont work (Mail-Server: http://www.cmfperception.com/liteserve.html) - with php.exe it will work

Second: The session.save_path will be ignored in php.ini and php try to use /tmp what cant be found on win and when i use the php.exe must be / instead of \ in the path when it should work


Hope i can help and sorry about my bad english (come from austria)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-07 18:58 UTC] edink@php.net
I suspect that your ISAPI module isn't reading correct php.ini. You can verify this by looking on top of phpinfo() output page were the used php.ini file will be specified. I just tested mail() and it works correctly.

You could also try to specify the two ini parameters in the scripts itself:

ini_set('SMTP', 'mail.example.com');
ini_set('sendmail_from', 'test@example.com');
mail("test@example.com", "test", "test");

 [2003-01-07 21:24 UTC] support at rhsoft dot net
Eys thats correct, it dont use any php.ini
But that is here of course and with php.exe it will be used

I had it in the same directory as php.exe and php4isapi.dll
since php 4.3.0 this works perfectly and is no need to copy it to win dir - i copied php4isapi in the root path of the interpreter so i can use relative path to the extension dir with only extension_dir = extensions but now nothing of all them will work 

I ve tried also to copy php.ini in the windir but it dont work with isapi but phpinfo shows  extension_dir = c:\php4 and i dont know from where this value comes

maybe - my windows is installed on K:\ 
php is installed in k:\server\php

hope this small bug will alos fixed in next release when anybody found it

where have you php installed ?
 [2003-01-08 03:31 UTC] edink@php.net
What does "Configuration File (php.ini) Path" from phpinfo() show?

And please use "Edit Submition" and "Add Comment" for the bug report.
 [2003-01-08 03:54 UTC] support at rhsoft dot net
now i know why it is so
the php.exe uses a php.ini-file when it is in same directory also but with the isapi it must be in the windir

dont really know why this is different 

about the button 
sorry if i used the developer
 [2003-01-08 04:58 UTC] edink@php.net
OK. So I assume that this is not a bug in PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon May 10 02:01:22 2021 UTC