php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21467 crash without any error
Submitted: 2003-01-06 11:34 UTC Modified: 2003-01-07 03:48 UTC
From: ceco at noxis dot net Assigned:
Status: Not a bug Package: Class/Object related
PHP Version: 4.3.0 OS: linux debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ceco at noxis dot net
New email:
PHP Version: OS:

 

 [2003-01-06 11:34 UTC] ceco at noxis dot net
when I try this

<?
        class test {
                function test(){
                        echo 'b';
                }
                function test($a){
                        echo 'a';
                }
        }

?>done

I minimized the problem, which I found with an old code using FastTemplate

nothing happens - no errors, no warning, no output - just sending headers and thats all

I am not sure if it is leagal code, but I'm sure it should get some error or warning message at least, or work of course

I installed it on apache web server, but the cli version is working the same way ( not working )

compiled the PHP with --enable-debug, and still no difference - no messages of any kind

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-06 11:37 UTC] ceco at noxis dot net
forgot to mention that the version it worked correctly is 4.1.2

(if can be defined correctly at all, i mean the script was working)
 [2003-01-06 16:24 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

I am not sure why you are not seeing an error, it could be due to error_reporting being set to 0 or php.ini directive indicate errors should not be shown.
The code you have does generate a fatal error, for your benefit I am including it here:
PHP Fatal error:  Cannot redeclare test() in c.php on line 6
php4/c.php(6) : Fatal error - Cannot redeclare test()

Fatal error: Cannot redeclare test() in c.php on line 6
 [2003-01-07 03:32 UTC] ceco at noxis dot net
I reported it because in php there is only one line containing error_reporting, and it is

error_reporting =       7
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 27 09:03:33 2021 UTC