php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21434 Can't SSI include more than one PHP page
Submitted: 2003-01-05 10:43 UTC Modified: 2003-01-05 10:44 UTC
From: jmanning at alisa-jon dot net Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.2 OS: Redhat Linux 8.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jmanning at alisa-jon dot net
New email:
PHP Version: OS:

 

 [2003-01-05 10:43 UTC] jmanning at alisa-jon dot net
This may be a apache2 SSI bug, I'll report something to them too.

Sample page (borrowed from a similar error I found online)
Standard SHTML.
<html><head><title>Test</title></head>
<body>
<center>
<p>Below, include #1 (hello.php) should appear:</p>
[ <!--#include="hello.php" --> ]

<p><hr></p><p>Below, include #2 (hello2.php) should appear :</p>
[ <!--#include="hello2.php" --> ]
</body></html>
 
hello.php
<?php echo "HELLO World, include #1"; ?>

hello2.php
<?php echo "HELLO World, include #2"; ?>

Only the first one runs as PHP. The second includes the source of the page into the html document.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-05 10:44 UTC] derick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.
 [2003-01-05 10:44 UTC] jmanning at alisa-jon dot net
http://www.sport4ever.com/test/hello.shtml

This is an example page. This belongs to someone else, but it was the me too I found that made me realize this error wasn't just me.
 [2003-01-05 11:23 UTC] jmanning at alisa-jon dot net
It took a while, but I found the dup.

Bug 17868

http://bugs.php.net/bug.php?id=17868
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Mar 01 01:01:28 2024 UTC