php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #21418 Changing PEAR::DB
Submitted: 2003-01-04 17:18 UTC Modified: 2003-01-04 19:36 UTC
From: bmichael at goldparrot dot com Assigned:
Status: Not a bug Package: Feature/Change Request
PHP Version: 4.2.3 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
32 + 27 = ?
Subscribe to this entry?

 
 [2003-01-04 17:18 UTC] bmichael at goldparrot dot com
I am justing getting into working with the PEAR::DB and DB_DataObjects code.

I have some changes that I am making to PEAR::DB and would like to know who to talk to or how I should submit those changes.

The following is what I am changing:

In PEAR::DB common.php file:
   Added  an new option to the $options array:
             'setPrefetch' => 1

For advanced Oracle queries, you use the OCI8setPrefetch limit to > 1. Other databases might find this useful for processing large queries if supported by the database type.

Secondly, in PEAR::DB DB.php
   I am adding a fetchStatement routine to DB_result class that supports limiting and the rownum feature.  This then calls the appropriate $this->dbh->fetchStatement() routine.

There are others as well, adding a static variable to numCols and numRows so that fetchStatement can load these variables, while fetchInto and fetchRow stills functions as expected.

In DB_oci8, changed constructor to use OCI8setPrefetch based upon the $this->option["setPrefetch"]

Created an OCI8setPrefetch function so that it can be called specifically/dynamically when the option changes. Currently the change only is reflected in new DB objects after setOptions is called.

As mentioned, changed numRows/numCols also in DB_oci8.

Adding DB_AUTOQUERY_DELETE to buildManipSQL.

Other changes, I am adding. Get number of rows for table in tableInfo for oci8.  Can use statistics from the table or use COUNT(*) - I will be doing this shortly.

I am doing a very large project with PEAR::DB and DB_DataObjects using Oracle to start, with versions running on mysql, mssql, potentially access, db2, Sybase, etc.  

In doing so, I have created an offshoot of DB_Dataobjects that will fully sustain many Databases in the same fashion as PEAR::DB. Alan and I have already talked about it.  But I am just informing the community.

How can I submit the changes to the PEAR::DB code.      

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-04 17:44 UTC] nicos@php.net
Not a bug please talk about it in php-pear-dev@lists.php.net.

Try to contact the leader of the package who is Stig ssb@fast.no or look at http://pear.php.net/package-info.php?pacid=46.

If you want to join the PEAR developper team please fill http://pear.php.net/account-request.php

Thank you for your report.
 [2003-01-04 19:36 UTC] philip@php.net
It's actually: pear-dev@lists.php.net
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 20 01:05:45 2022 UTC