php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21393 Apache crashes when loading oracle dlls
Submitted: 2003-01-03 10:04 UTC Modified: 2003-01-03 10:20 UTC
From: kamal80 at virgilio dot it Assigned:
Status: Not a bug Package: Oracle related
PHP Version: 4.3.0 OS: windows 2000 prof. sp3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kamal80 at virgilio dot it
New email:
PHP Version: OS:

 

 [2003-01-03 10:04 UTC] kamal80 at virgilio dot it
The Apache service (1.3.27) just crashes if my php.ini tries to load both php_oci8.dll and php_oracle.dll.

My oracle client version is the last 8.1.7.
My pc is a P4 2.5Ghz.

My configuration is very simple. If I try to load each of the dlls alone it works fine.
I hope this isn't a normal result, I didn't find this information in the php.ini or somewhere else. I have to say that I didn't search very well.

Kamal

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-03 10:17 UTC] rasmus@php.net
I don't understand why you want to load both.  The OCI8 extension supports the oci7 protocol.
 [2003-01-03 10:20 UTC] derick@php.net
There is no need to load both the .dll's as the oci8 one supports the Oracle versions supported by the oracle dll. They both make use of the libraries installed on your system and it's simply asking for problems if you load both .dll due to symbol clashes. Not a bug -> bogus
 [2003-01-05 14:24 UTC] kamal80 at virgilio dot it
Ok, I've understood. Thank you for the answers.

Just a little comment: wouldn't it be better to just load the oci8 if someone tries to load both?
Maybe it's a perfectionism... I don't know, or maybe it's just unuseful. Or maybe it would be useful to find it written somewhere...
However, thank you for your job.

Kamal
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jun 16 22:01:30 2024 UTC