php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21382 install of phpDocumentor fails
Submitted: 2003-01-03 01:58 UTC Modified: 2003-05-31 13:50 UTC
Votes:2
Avg. Score:3.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: greg at chiaraquartet dot ent Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.3.0 OS: win98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: greg at chiaraquartet dot ent
New email:
PHP Version: OS:

 

 [2003-01-03 01:58 UTC] greg at chiaraquartet dot ent
using the web frontend, attempts to install phpDocumentor fail, due to inability to write to long path C:\phpdev\php-4.3.0-Win32\pear\phpDocumentor\phpDocumentor\Converters\CHM\default\templates\default\templates

probably because it's longer than 128 chars?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-03 04:57 UTC] katana at katana-inc dot com
I get the same error, or something similar, while installing http://pear.php.net/get/PhpDocumentor-1.2.0beta1.tgz, but this time on windows XP (PHP 4.3.0):

D:\programs\httpd\php>pear install http://pear.php.net/get/PhpDocumentor-1.2.0beta1.tgz
downloading PhpDocumentor-1.2.0beta1.tgz ...
...done: 666,630 bytes
failed to write \programs\httpd\php\pear\phpDocumentor\phpDocumentor\Converters\CHM\default\templates\default\templates\.tmpbasicindex.tpl
 [2003-01-03 18:42 UTC] jmcastagnetto@php.net
The problem is not OS specific, doing:



% pear install PhpDocumentor



downloading PhpDocumentor-1.2.0beta1.tgz ...

...done: 666,630 bytes

failed to write /export/dredox1/devel_server/php/lib/php/phpDocumentor/phpDocumentor/Converters/CHM/default/templates/default/templates/.tmpbasicindex.tpl



gives also an error on Solaris 8, using php4-CVS



I downloaded the tarball it does not seem to contain any file named ".tmpbasicindex.tpl". So the options were that (1) the tarball contents are fubared somehow (the list looks OK), or (2) PEAR::Archive_Tar is messing up at some point. 



To check the tarball, I just used Gnu tar:



% gtar -zxvf PhpDocumentor-1.2.0beta1.tgz



then:



% cd PhpDocumentor-1.2.0beta1/phpDocumentor/Converters/CHM/default/templates/default/templates



Finally:



% ls -Al

total 112

-rw-r--r--   1 jesusmc  asd          246 Dec 23 20:44 blank.tpl

-rw-r--r--   1 jesusmc  asd         2194 Dec 23 20:44 class.tpl

-rw-r--r--   1 jesusmc  asd          277 Jun 16  2002 hhp.tpl

-rw-r--r--   1 jesusmc  asd          675 Dec 23 20:44 index.tpl

-rw-r--r--   1 jesusmc  asd          777 Dec 23 20:44 page.tpl

-rw-r--r--   1 jesusmc  asd          125 Dec 23 18:05 ric.tpl

-rw-r--r--   1 jesusmc  asd         1248 Dec 23 20:44 var.tpl



And as you can see no ".tmpbasicindex.tpl" exists. Not even when I used:



% cd /tmp/PhpDocumentor-1.2.0beta1

% find ./ -name ".tmpbasicindex*" -print



Had not look at the PEAR::Archive_Tar yet
 [2003-01-03 19:04 UTC] jmcastagnetto@php.net
More clues.

To check if the problem was the creation of the tarball package itself I did:

% cd tmp/PhpDocumentor-1.2.0beta1
% cp ../package.xml .
% pear package
File phpDocumentor/Converters/CHM/default/templates/default/templates/basicindex.tpl does not exist

And indeed that file does not exist. I wonder how the package got created OK in the first place. 

The problem is line 247 in package.xml:

 <file role="php" baseinstalldir="phpDocumentor" md5sum="d93134f0d62acffaae22e14db015fb08" name="phpDocumentor/Converters/CHM/default/templates/default/templates/basicindex.tpl"/>

Commented that out and retried, giving another error:

"File phpDocumentor/Converters/CHM/default/templates/default/templates/classleft.tpl does not exist"

So I commented out the whole CHM section, and retrying I got:

File phpDocumentor/Converters/HTML/default/templates/default/constants_detail.inc.html does not exist

Bottomline. If Greg is using Windows to create the tarball, then that may be the reason why things are failing. Is there a limit to the paths in Windows? (I have no idea, I do not use that OS).

BTW, I just tried getting a to PhpDocumentor's CVS and got the error:

"...
U phpdoc/Documentation/Release-old/Release-1.1.0rc1
U phpdoc/Documentation/Release-old/Release-1.1.0rc2
cvs server: Updating phpdoc/Documentation/old
cvs server: failed to create lock directory for `/opt/cvsroot/phpdoc/Documentation/old' (/opt/cvsroot/phpdoc/Documentation/old/#cvs.lock): Permission denied
cvs server: failed to obtain dir lock in repository `/opt/cvsroot/phpdoc/Documentation/old'
cvs [server aborted]: read lock failed - giving up
..."

So I will download a snapshot and check what's going on.

 [2003-01-03 19:30 UTC] jmcastagnetto@php.net
Got a snapshot from http://developer.phpdoc.org/downloads/ (the phpdoc-20030102.tar.gz file), and modified the package.xml from the original (diff at the end of the msg).

Mangled the package.xml until "pear package" stopped complaining about missing/non existent files. And then I found that the problem indeed can be in PEAR::Archive_Tar, because of a limitation in the number of chars per filename and some broken logic (I think) in the code.

I have submitted a bug report on that. See bug #21402 for details.

Using Gnu diff (gdiff):

% gdiff -u package.xml-orig package.xml

--- package.xml-orig	Fri Jan  3 17:07:32 2003
+++ package.xml	Fri Jan  3 17:09:36 2003
@@ -84,59 +84,6 @@
    XML DocBook Converter.  Please try it out and find them so we can begin to fix
    them.</notes>
     <filelist>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="fa48d92cb63c3dcd964a307eded145c3" name="Documentation/old/Converterhowto-1.0old.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="817380ac9e876ff58c36db29fd6abb56" name="Documentation/old/Converterhowto.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="c1de3ab28ab7bf048cfcb0a3b6f971cf" name="Documentation/old/howto.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="8a768500e0700979cf0a83c80ea23ec6" name="Documentation/old/index.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="cd44b27eec2b42ca95d07a7c40f583ee" name="Documentation/old/Templatehowto.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="a0f591dd6296fe2d0b04c590d1a666c0" name="Documentation/old/tags/tags.access.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="461a210cc307b29ff60edca905a9f754" name="Documentation/old/tags/tags.author.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="daa7fe874e3b3d20f4e13fbeef40126a" name="Documentation/old/tags/tags.copyright.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="90b0ed6f8c6500beae4b070b4c82d67a" name="Documentation/old/tags/tags.deprecated.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="ca0a6b235c8e3fb2aef4276b8b0b6706" name="Documentation/old/tags/tags.global.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="f76211eeb5df0d2888d7ea79a688db01" name="Documentation/old/tags/tags.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="64b734f7e61925a1d7b9421fa4c989a0" name="Documentation/old/tags/tags.ignore.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="74e9e04fa5ebfea073ab1642701d6020" name="Documentation/old/tags/tags.inlineid.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="25db6c7244420d1931f03ab61445a0bd" name="Documentation/old/tags/tags.inlineinheritdoc.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="fdec24e1130df87f5b1c2144c38ba922" name="Documentation/old/tags/tags.inlinelink.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="dc474e36a19e397c78345d2a671de8df" name="Documentation/old/tags/tags.inlinesource.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="4c454faa9611d7911b8a41fc21a6b8a2" name="Documentation/old/tags/tags.link.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="f6ff0bae87c1d7d0f34b2019f2e46adb" name="Documentation/old/tags/tags.name.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="58d85d9e26fb49ba1a6195187efbd4b8" name="Documentation/old/tags/tags.package.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="fce08e9ac993b00781f8c55e26b3554d" name="Documentation/old/tags/tags.param.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="07b70ab8eb37b89aae107b1e3ac5431a" name="Documentation/old/tags/tags.return.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="1a8224255593bf090eff60ae8c9ea986" name="Documentation/old/tags/tags.see.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="240f5e8396feb87bdf5f0e9cc814ce04" name="Documentation/old/tags/tags.since.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="66d4f6d87b493870556962d88b3b2db1" name="Documentation/old/tags/tags.staticvar.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="74963c3d0b925cf86c1459a5ea66c5bc" name="Documentation/old/tags/tags.subpackage.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="f7e95d37d51b3501d510a47cf4284b78" name="Documentation/old/tags/tags.var.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="132ae0df4dab0a83f08687287e013b8e" name="Documentation/old/tags/tags.version.html"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="4906b5b6cce8ec88219f7ebe37b1b5f7" name="Documentation/old/tags/_fake_page_php.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="c51f179a787cd24747ed62f9a9343191" name="Documentation/old/templates/class.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="50382888e86c0f82acbdfac2f2288d82" name="Documentation/old/templates/classtrees.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="99c30d79f60aaa87621a3cf22a29dab3" name="Documentation/old/templates/constants_detail.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="4f6b3d7da37bae16943af6ab9e585bd8" name="Documentation/old/templates/constants_summary.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="7b786f1a6d3e02bb8bf70a6de10dfc04" name="Documentation/old/templates/docblock-func.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="0e63645d0c4589d5f59a897871c6a40a" name="Documentation/old/templates/docblock.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="e6d086ebdc99a51ce36df6bbc9bf24cd" name="Documentation/old/templates/elementindex.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="f6eac6072fa6b689aa155a1be84415b7" name="Documentation/old/templates/functions_detail.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="1aac39e2c356d7ea6f2ce62c98b06564" name="Documentation/old/templates/functions_inherited.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="4f13178af7476d2450c967f480ec0dc9" name="Documentation/old/templates/functions_summary.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="0463b1d254087d2cd85596430c2eedc8" name="Documentation/old/templates/globals_detail.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="a9011ed020bd97b2fa344a503a2903c7" name="Documentation/old/templates/globals_summary.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="94ec27513128b6b52ff1ee64d55e4e6c" name="Documentation/old/templates/includes_detail.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="f972d031ae7a7daa86bd826d6627e6a4" name="Documentation/old/templates/includes_summary.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="c84acc7aa5f5adf89aae0157c4389a4e" name="Documentation/old/templates/index.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="8346e73bd05e139feef7f37ee11e37e8" name="Documentation/old/templates/left.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="a9d339d02c241b59d1d610310d109fd4" name="Documentation/old/templates/packages.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="2fbe430adbdf8d1f12ee8af3e7ea8eb2" name="Documentation/old/templates/page.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="fffd30dd8b3dbf09c1ed6a4902c5516e" name="Documentation/old/templates/pagefoot.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="b7e7db52abc62ada3a5f2ba32a71612a" name="Documentation/old/templates/pagetop.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="5aff6e126ede25feface72a4dd1bc5ea" name="Documentation/old/templates/pkgelementindex.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="7a638b52cae09134bc05ce6888c72916" name="Documentation/old/templates/templates.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="b5765990dcc05050dcf6bf1d8ca32687" name="Documentation/old/templates/vars_detail.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="346d68b7f7deacb710436a8c2d6da2b9" name="Documentation/old/templates/vars_inherited.inc.html"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="b788662c8db03c1a2a9ba483400d518e" name="Documentation/old/templates/vars_summary.inc.html"/>
       <file role="doc" baseinstalldir="phpDocumentor" md5sum="7a19d598a33b6cd1d6d0288bff81f773" name="Documentation/Release-old/Release-0.2.4"/>
       <file role="doc" baseinstalldir="phpDocumentor" md5sum="ac5427305cd123061737e921d8effddf" name="Documentation/Release-old/Release-0.2.5"/>
       <file role="doc" baseinstalldir="phpDocumentor" md5sum="b5eb74f9c46ab9aaabc5fc3b3228c856" name="Documentation/Release-old/Release-0.2.6"/>
@@ -950,8 +897,6 @@
       <file role="php" baseinstalldir="phpDocumentor" md5sum="428f3c3986fbcb5334330625379bf7d2" name="tutorials/phpDocumentor/elements.pkg"/>
       <file role="php" baseinstalldir="phpDocumentor" md5sum="194e0449cc7ac5d12d3c61d3cf6dc46e" name="tutorials/phpDocumentor/inlinetags.pkg"/>
       <file role="php" baseinstalldir="phpDocumentor" md5sum="daa5e854620939b0a82565c5e2d9fd76" name="tutorials/phpDocumentor/inlinetags.pkg.ini"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="34edef3458c8c342db26131be6174c25" name="tutorials/phpDocumentor/manual.pkg"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="2c7bef1340c374d82c45bf8729f25fce" name="tutorials/phpDocumentor/manual.pkg.ini"/>
       <file role="php" baseinstalldir="phpDocumentor" md5sum="82d1a49f5a54a498ce3e003eae490883" name="tutorials/phpDocumentor/phpDocumentor.howto.pkg"/>
       <file role="php" baseinstalldir="phpDocumentor" md5sum="cd8bd7c8cd7641ba3ec3dff39ae249bc" name="tutorials/phpDocumentor/phpDocumentor.howto.pkg.ini"/>
       <file role="php" baseinstalldir="phpDocumentor" md5sum="015f6359bddfcb4a42a35e2d4eb24068" name="tutorials/phpDocumentor/phpDocumentor.pkg"/>
@@ -987,7 +932,6 @@
       <file role="php" baseinstalldir="phpDocumentor" md5sum="2be40fe0fe31a496d4390ace74cf41d6" name="tutorials/phpDocumentor/tutorials.pkg"/>
       <file role="php" baseinstalldir="phpDocumentor" md5sum="b6a38f6162da2073915167b2ee8b9552" name="user/default.ini"/>
       <file role="php" baseinstalldir="phpDocumentor" md5sum="73b3635531bd07994ac1493a6caba02f" name="user/demo.ini"/>
-      <file role="php" baseinstalldir="phpDocumentor" md5sum="da6aac20a9bbc8ae8a1e0486d80fd0ef" name="user/testdocbook.ini"/>
       <file role="php" baseinstalldir="phpDocumentor" md5sum="8daf5594000c31f79f8bc7d02489f3a4" name="index.html"/>
       <file role="doc" baseinstalldir="phpDocumentor" md5sum="458e20ee6dcb905051224b6510bb3d8d" name="INSTALL"/>
       <file role="php" baseinstalldir="phpDocumentor" md5sum="715d1de9920f5c6d52ac75a139fd2a69" name="new_phpdoc.php"/>
@@ -996,7 +940,6 @@
       <file role="php" baseinstalldir="phpDocumentor" md5sum="f1d7e22b6c07b535ea2b027cf90ed672" name="phpDocumentor.ini"/>
       <file role="php" baseinstalldir="phpDocumentor" md5sum="fb849b7d57e8eaffc3f1b3918349fc7d" name="poweredbyphpdoc.gif"/>
       <file role="doc" baseinstalldir="phpDocumentor" md5sum="3fb416d14514c66a1a8a04ed47e94f87" name="README"/>
-      <file role="doc" baseinstalldir="phpDocumentor" md5sum="2504fa2d383828dcc59dcc099d316c8b" name="Release-1.2.0beta1"/>
     </filelist>
   </release>
   <changelog>

 [2003-02-02 16:42 UTC] greg at chiaraquartet dot ent
Installing PhpDocumentor on linux does not install any of the role="script" files (phpdoc), and gives no errors

installing on windows gives an error, 

downloading PhpDocumentor-1.2.0beta3.tgz ...
...done: 955,681 bytes

failed to write \phpdev\php-4.3.0-Win32\PEAR\PhpDocumentor\phpDocumentor\Converters\HTML\default\templates\default\.tmpstylesheet.css

I have upgraded all packages to the most recent upgrade.

Note that stylesheet.css is a 0-byte file in that directory, perhaps this is causing a problem?  The file is present in the archive

This means pear install PhpDocumentor doesn't work on any OS.  Might need fixing to match claim of 1.0
 [2003-05-31 13:50 UTC] greg at chiaraquartet dot ent
this is fixed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 15:03:35 2021 UTC