php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21367 FastCGI -b option error
Submitted: 2003-01-02 19:54 UTC Modified: 2003-01-25 16:07 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: fserb at terra dot com dot br Assigned: shane (profile)
Status: Closed Package: Other web server
PHP Version: 4.3.0 OS: WinXP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: fserb at terra dot com dot br
New email:
PHP Version: OS:

 

 [2003-01-02 19:54 UTC] fserb at terra dot com dot br
I've downloaded the full Win32 PHP binary and the "-b" argument that should "Bind Path for external FASTCGI server mode" doesn't work.

What happens is:
c:\php>php -b 5000
Error in argument 1, char 2: option not found b
Error in argument 1, char 2: option not found b
Error in argument 1, char 2: option not found b

I read on php.dev newsgroup that this is the right way to start FastCGI support since SAPI/FastCGI was discontinued.
But it doesn't work.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-13 17:41 UTC] sniper@php.net
-b is not available for fastcgi binary..iirc, the binary
provided in the release package is compiled with the fastcgi support turned on. You can check that with 'php -v'
 [2003-01-13 17:47 UTC] edink@php.net
Verified:

C:\php4>php -v
PHP 4.3.0 (cgi-fcgi), Copyright (c) 1997-2002 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2002 Zend Technologies

C:\php4>php -h
[snip]
  -b <address:port>|<port> Bind Path for external FASTCGI Server mode
[snip]

C:\php4>php -b 127.0.0.1:12345
Error in argument 1, char 2: option not found b
Error in argument 1, char 2: option not found b
Error in argument 1, char 2: option not found b
 [2003-01-13 17:51 UTC] sniper@php.net
"-b is ONLY available" was what I wanted to say. :)
Anyway, if you have any of these set in your environment:

SERVER_SOFTWARE
SERVER_NAME
GATEWAY_INTERFACE
REQUEST_METHOD

then it won't be available.


 [2003-01-13 20:44 UTC] fserb at terra dot com dot br
My "php -v" and "php -h" are exactly equal as the above one.

I don't have any of those envvars set and it still doesn't work.
 [2003-01-25 16:07 UTC] shane@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

This is now fixed in cvs:
4.3: http://cvs.php.net/co.php/php4/sapi/cgi/cgi_main.c?r=1.190.2.12
5.0: http://cvs.php.net/co.php/php4/s
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Feb 26 05:01:25 2024 UTC