php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21359 Pear install failes on NFS and many other networked file systems
Submitted: 2003-01-02 17:21 UTC Modified: 2003-01-02 17:21 UTC
From: fredrikr at ipfw dot edu Assigned:
Status: Not a bug Package: PEAR related
PHP Version: 4.3.0 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fredrikr at ipfw dot edu
New email:
PHP Version: OS:

 

 [2003-01-02 17:21 UTC] fredrikr at ipfw dot edu
Make install with the related install-pear-* make directives will fail on NFS and many other networked file systems. 

Due to the use of flock() in php-4.3.0/pear/PEAR/Registry.php at line 282. 

A possable fix is to handle the block while locking on netword file systems via the use of the LOCK_NB operation.

See: http://www.php.net/manual/en/function.flock.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-02 17:21 UTC] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC