php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21339 cannot compile gettext support
Submitted: 2003-01-02 10:28 UTC Modified: 2003-02-10 12:43 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: gobbers at faw dot uni-ulm dot de Assigned:
Status: Not a bug Package: Gettext related
PHP Version: 4.3.0 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gobbers at faw dot uni-ulm dot de
New email:
PHP Version: OS:

 

 [2003-01-02 10:28 UTC] gobbers at faw dot uni-ulm dot de
Compiler: SUNWspro 5.0 (same with gcc 2.95.2)

# ./configure --prefix=/lfs/web1/php-4.2.3 --with-apxs=/lfs/web1/apache-1.3.27/bin/apxs --enable-safe-mode --with-exec-dir=/lfs/web1/php-bin --with-openssl=/lfs/web1/openssl-0.9.6g --with-zlib-dir=/lfs/web1/zlib-1.1.4 --enable-calendar --with-gdbm=/lfs/web1/gdbm-1.8.0 --enable-dbx --enable-ftp --with-gd=/lfs/web1/gd-2.0.8 --with-jpeg-dir=/lfs/web1/libjpeg-6b --with-png-dir=/lfs/web1/libpng-1.2.5 --enable-gd-native-ttf --with-mysql=/lfs/web1/mysql-3.23.39 --with-oci8=/lfs/web1/oracle-8.1.7 --with-pdflib=/lfs/web1/pdflib-4.0.3 --with-mm=/lfs/web1/mm-1.1.3 --enable-sockets --enable-sysvsem --enable-sysvshm --with-zip=/lfs/web1/zziplib-0.10.27 --with-gettext=/lfs/web1/gettext-0.11.5 --with-iconv=/lfs/web1/libiconv-1.8

# make (only significant part)
/bin/sh libtool --silent --mode=compile cc  -Iext/gettext/ -I/lfs/scratch/apache-1.3.27-build/php-4.3.0/ext/gettext/ -DPHP_ATOM_INC -I/lfs/scratch/apache-1.3.27-build/php-4.3.0/include -I/lfs/scratch/apache-1.3.27-build/php-4.3.0/main -I/lfs/scratch/apache-1.3.27-build/php-4.3.0 -I/lfs/scratch/apache-1.3.27-build/php-4.3.0/Zend -I/lfs/web1/openssl-0.9.6g/include -I/lfs/web1/zlib-1.1.4/include -I/lfs/web1/gdbm-1.8.0/include -I/lfs/web1/libjpeg-6b/include -I/lfs/web1/libpng-1.2.5/include -I/lfs/web1/gd-2.0.8/include -I/lfs/web1/gettext-0.11.5/include -I/lfs/web1/libiconv-1.8/include -I/lfs/web1/mysql-3.23.39/include/mysql -I/lfs/web1/oracle-8.1.7/rdbms/public -I/lfs/web1/oracle-8.1.7/rdbms/demo -I/lfs/web1/pdflib-4.0.3/include -I/lfs/web1/mm-1.1.3/include -I/lfs/scratch/apache-1.3.27-build/php-4.3.0/ext/xml/expat -I/lfs/web1/zziplib-0.10.27/include  -D_POSIX_PTHREAD_SEMANTICS -DSOLARIS2=280 -DMOD_SSL=208112 -DMOD_PERL -DUSE_PERL_SSI -DEAPI -DEAPI_MM -I/lfs/scratch/apache-1.3.27-build/php-4.3.0/TSRM  -fast -xtarget=ultra -xarch=v8a  -prefer-pic -c /lfs/scratch/apache-1.3.27-build/php-4.3.0/ext/gettext/gettext.c -o ext/gettext/gettext.lo
"/lfs/scratch/apache-1.3.27-build/php-4.3.0/ext/gettext/gettext.c", line 37: undefined symbol: zif_libintl_textdomain
"/lfs/scratch/apache-1.3.27-build/php-4.3.0/ext/gettext/gettext.c", line 37: warning: improper pointer/integer combination: op "="

...(stripped of a lot of look a likes)...

"/lfs/scratch/apache-1.3.27-build/php-4.3.0/ext/gettext/gettext.c", line 37: non-constant initializer: op "NAME"
"/lfs/scratch/apache-1.3.27-build/php-4.3.0/ext/gettext/gettext.c", line 282: identifier redeclared: zif_libintl_bind_textdomain_codeset
        current : function(int, pointer to struct _zval_struct {union _zvalue_value {..} value, uchar type, uchar is_ref, ushort refcount}, po...
        previous: int : "/lfs/scratch/apache-1.3.27-build/php-4.3.0/ext/gettext/gettext.c", line 53
cc: acomp failed for /lfs/scratch/apache-1.3.27-build/php-4.3.0/ext/gettext/gettext.c
*** Error code 1
make: Fatal error: Command failed for target `ext/gettext/gettext.lo'



I can get the compile working if I move "function_entry php_gettext_functions[]" and "zend_module_entry php_gettext_module_entry" to the end of the gettext.c file but than I get an UNREF for "zm_info_gettext"...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-13 18:55 UTC] sniper@php.net
Could you try with an older gettext version?
Like 0.10.40, which I know works for sure.

 [2003-01-14 10:14 UTC] gobbers at faw dot uni-ulm dot de
I've tried gettext 0.10.40 but got the same unreferenced symbol.
 [2003-01-14 19:19 UTC] sniper@php.net
Try this configure line:

./configure --disable-all --with-gettext=/path/to/gettext/install/prefix

And if that causes the same problem, try this:

./configure --disable-all --with-gettext

This way we can rule out the possibility of other extensions
being the reason..

 [2003-02-04 05:40 UTC] gobbers at faw dot uni-ulm dot de
I've tried compiling it with 
./configure --disable-all --with-gettext=/path/to/gettext/install/prefix
but still failed. I've given up for now as I've other issues which are more important...
 [2003-02-10 12:43 UTC] sniper@php.net
Works fine here, user has more important issues to deal with and can't provide feedback, and this most likely is some user error anyway.

 [2004-09-28 14:03 UTC] martynas at ti dot com
Hello

I have similar problem here with php 4.3.3, gettext 0.13 and SUNWspro 5.5 compiler. I tried to run configure like you said ("./configure --disable-all --with-gettext=/opt/local/gettext/") and here's a result for latest command :

cc  -Imain/ -I/export/home/compile/soft/web/php-4.3.3/main/ -DPHP_ATOM_INC -I/export/home/compile/soft/web/php-4.3.3/include -I/export/home/compile/soft/web/php-4.3.3/main -I/export/home/compile/soft/web/php-4.3.3 -I/export/home/compile/soft/web/php-4.3.3/Zend -I/opt/local/gettext//include  -D_POSIX_PTHREAD_SEMANTICS -I/export/home/compile/soft/web/php-4.3.3/TSRM  -Xa -fast -native -xstrconst -mt -xarch=v9  -c main/internal_functions.c -o main/internal_functions.o  && echo > main/internal_functions.lo
/bin/sh /export/home/compile/soft/web/php-4.3.3/libtool --silent --preserve-dup-deps --mode=link cc -export-dynamic -Xa -fast -native -xstrconst -mt -xarch=v9  -L/usr/ucblib -L/opt/local/gettext//lib -xarch=v9 -R /usr/ucblib -R /opt/local/gettext//lib ext/gettext/gettext.lo ext/standard/array.lo ext/standard/base64.lo ext/standard/basic_functions.lo ext/standard/browscap.lo ext/standard/crc32.lo ext/standard/crypt.lo ext/standard/cyr_convert.lo ext/standard/datetime.lo ext/standard/dir.lo ext/standard/dl.lo ext/standard/dns.lo ext/standard/exec.lo ext/standard/file.lo ext/standard/filestat.lo ext/standard/flock_compat.lo ext/standard/formatted_print.lo ext/standard/fsock.lo ext/standard/head.lo ext/standard/html.lo ext/standard/image.lo ext/standard/info.lo ext/standard/iptc.lo ext/standard/lcg.lo ext/standard/link.lo ext/standard/mail.lo ext/standard/math.lo ext/standard/md5.lo ext/standard/metaphone.lo ext/standard/microtime.lo ext/standard/pack.lo ext/standard/pageinfo.lo ext/standard/parsedate.lo ext/standard/quot_print.lo ext/standard/rand.lo ext/standard/reg.lo ext/standard/soundex.lo ext/standard/string.lo ext/standard/scanf.lo ext/standard/syslog.lo ext/standard/type.lo ext/standard/uniqid.lo ext/standard/url.lo ext/standard/url_scanner.lo ext/standard/var.lo ext/standard/versioning.lo ext/standard/assert.lo ext/standard/strnatcmp.lo ext/standard/levenshtein.lo ext/standard/incomplete_class.lo ext/standard/url_scanner_ex.lo ext/standard/ftp_fopen_wrapper.lo ext/standard/http_fopen_wrapper.lo ext/standard/php_fopen_wrapper.lo ext/standard/credits.lo ext/standard/css.lo ext/standard/var_unserializer.lo ext/standard/ftok.lo ext/standard/aggregation.lo ext/standard/sha1.lo regex/regcomp.lo regex/regexec.lo regex/regerror.lo regex/regfree.lo TSRM/TSRM.lo TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/main.lo main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/safe_mode.lo main/fopen_wrappers.lo main/alloca.lo main/php_scandir.lo main/php_ini.lo main/SAPI.lo main/rfc1867.lo main/php_content_types.lo main/strlcpy.lo main/strlcat.lo main/mergesort.lo main/reentrancy.lo main/php_variables.lo main/php_ticks.lo main/streams.lo main/network.lo main/php_open_temporary_file.lo main/php_logos.lo main/output.lo main/memory_streams.lo main/user_streams.lo Zend/zend_language_parser.lo Zend/zend_language_scanner.lo Zend/zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/zend_alloc.lo Zend/zend_compile.lo Zend/zend_constants.lo Zend/zend_dynamic_array.lo Zend/zend_execute_API.lo Zend/zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_execute.lo sapi/cgi/cgi_main.lo sapi/cgi/getopt.lo main/internal_functions.lo -lintl -lresolv -lm -ldl -lnsl -lsocket  -o sapi/cgi/php
Undefined                       first referenced
 symbol                             in file
php_gettext_module_entry            main/internal_functions.o
ld: fatal: Symbol referencing errors. No output written to sapi/cgi/php
*** Error code 1
make: Fatal error: Command failed for target `sapi/cgi/php'


Any ideas ?

With best regards
Martynas
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 30 01:01:27 2020 UTC