|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21273 memory_limit seems to be ignored
Submitted: 2002-12-29 14:32 UTC Modified: 2003-01-13 18:19 UTC
Avg. Score:3.8 ± 0.8
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:1 (25.0%)
From: emailtotom at gmx dot de Assigned:
Status: No Feedback Package: PHP options/info functions
PHP Version: 4.3.0 OS: Windows 2000 service pack 3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: emailtotom at gmx dot de
New email:
PHP Version: OS:


 [2002-12-29 14:32 UTC] emailtotom at gmx dot de
I have memory_limit = 8M in php.ini (c:\winnt\php.ini)
phpinfo(); doesn't show me the limit. Also the limit is not obeyed. I can make big fsockopen(),  fgets no error.
The same with memory_limit=4M or 16M

(php is standard from downloaded win32 binary, php-ini-dist)

Is there something new in php 4.3 ??


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-29 14:37 UTC]
What does phpinfo() tell you about the location of php.ini?

 [2002-12-29 14:39 UTC] emailtotom at gmx dot de
Configuration File (php.ini) Path  C:\WINNT\php.ini  

You need a screenshot ?
 [2002-12-29 14:51 UTC] emailtotom at gmx dot de
seems to be the same with php 4.2.3 am I doing something wrong ?
 [2003-01-13 18:19 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

 [2003-03-08 23:34 UTC] pmoulding at tedis dot com dot au
I ran a test using PHP 4.3.0 and the latest Apache 2 on a little NT workstation. The test added a 1 Mb string to an array 1000 times. The test ran to completion despite php.ini containing a limit of 8M.

I ran the test because I need an example page showing the memory limit exceeded message. So far, the message has not popped up no matter what I do.

I sometimes use .htaccess but not in the Web site where I ran the test so .htaccess is not overriding php.ini.

The Apache .conf has the bare minimum settings to get PHP running. The settings should not overriding PHP.ini. 

PHP is installed using the 4.3.0 release binary so has no compile time overrides by me. I use the module version, not CGI.

The test script ran quickly so I though PHP might have dropped the extra data. NT reported the process using the full gigabyte so PHP must have allocated the gigabyte.

Are there additional places where I should look for memory limit overrides? If not then the php.ini memory_limit setting has no effect.

I looked through other error reports and found only one similar error open in 22158. There are closed error reports suggesting the error is caused by .htaccess or .conf which is why I looked there before reporting this problem.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Apr 17 22:01:26 2024 UTC