php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21251 ??4.2.3????????????4.3.0?б???!
Submitted: 2002-12-28 11:19 UTC Modified: 2003-01-04 03:12 UTC
From: vwbox at sohu dot com Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 4.3.0 OS: winnt4sp6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vwbox at sohu dot com
New email:
PHP Version: OS:

 

 [2002-12-28 11:19 UTC] vwbox at sohu dot com
?????ܲ???һ???�????Ҫ˵???ǻ??????????ֵܵķ??գ?????????????Ϊ????Ӧ????˵????????ע????

??php.ini?????У?include_path = ".;d:\yours\include;d:\haha"
??ʽ?????????°???php???????⣬?????ǣ????????ڳ?????ʹ??require()??include()????include_once()???????????Ҳ????????????ļ???

???????ⷳ??????5~6????Сʱ?????????Ҳ?и?ĵ????£?????ʹ??"/"??????"\"?????Ժ?Ϳ?????ȷ???ð????ļ?.

?ҵĻ?????winnt4sp6+apache1.3.27+php4.3.0

mr..vw
vwbox@sohu.com

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-28 11:21 UTC] iliaa@php.net
In english please.
 [2003-01-04 03:12 UTC] vwbox at sohu dot com
?????ܲ???һ???�????Ҫ˵???ǻ??????????ֵܵķ??գ?????????????Ϊ????Ӧ
????˵????????ע????

??php.ini?????У?include_path = ".;d:\yours\include;d:\haha"
??ʽ?????????°???php???????⣬?????ǣ????????ڳ?????ʹ??require()??incl
ude()????include_once()???????????Ҳ????????????ļ???

???????ⷳ??????5~6????Сʱ?????????Ҳ?и?ĵ????£?????ʹ??"/"??????"\" ?????Ժ?Ϳ?????ȷ???ð????ļ?.

?ҵĻ?????winnt4sp6+apache1.3.27+php4.3.0

mr..vw
vwbox@sohu.com
=========================================================
??????ͬ??Ӣ?? == Follows are English report in same mean 
=========================================================
Although It isn't a bug that I believed,But it should be reported! Because It would make many others mistake in their config files.
  The bug is :when you want set your include file's forder with include_path = ".;d:\yours\include;d:\haha" in your php.ini file,as the samples, the PHP program will tell you that He can not find the file in d:\haha of your "include ("aaa.inc");"!

It takes me for about 5~6 hours to find a way that you can use "/" but "\" instead! The program tells me that there are errors,but I cannot find it! And the answer is so simple!

My Os is winnt4sp6+apache1.3.27+php4.3.0


mr..vw
vwbox@sohu.com
===================================================
?ҵ?ĸ???Ǻ??????Ϊ??????Ӣ????ѧ???ˣ?Ҫ?????ﲻ??????ֻ???鷳???????ﱨ???ˣ???????˼??==== My motherlanguage is Chinese , and I find chinese is more easy to study than English! If there are something troubled you, Please read My Chinese report instead.
 [2003-01-04 03:12 UTC] vwbox at sohu dot com
?????ܲ???һ???�????Ҫ˵???ǻ??????????ֵܵķ??գ?????????????Ϊ????Ӧ
????˵????????ע????

??php.ini?????У?include_path = ".;d:\yours\include;d:\haha"
??ʽ?????????°???php???????⣬?????ǣ????????ڳ?????ʹ??require()??incl
ude()????include_once()???????????Ҳ????????????ļ???

???????ⷳ??????5~6????Сʱ?????????Ҳ?и?ĵ????£?????ʹ??"/"??????"\" ?????Ժ?Ϳ?????ȷ???ð????ļ?.

?ҵĻ?????winnt4sp6+apache1.3.27+php4.3.0

mr..vw
vwbox@sohu.com
=========================================================
??????ͬ??Ӣ?? == Follows are English report in same mean 
=========================================================
Although It isn't a bug that I believed,But it should be reported! Because It would make many others mistake in their config files.
  The bug is :when you want set your include file's forder with include_path = ".;d:\yours\include;d:\haha" in your php.ini file,as the samples, the PHP program will tell you that He can not find the file in d:\haha of your "include ("aaa.inc");"!

It takes me for about 5~6 hours to find a way that you can use "/" but "\" instead! The program tells me that there are errors,but I cannot find it! And the answer is so simple!

My Os is winnt4sp6+apache1.3.27+php4.3.0


mr..vw
vwbox@sohu.com
===================================================
?ҵ?ĸ???Ǻ??????Ϊ??????Ӣ????ѧ???ˣ?Ҫ?????ﲻ??????ֻ???鷳???????ﱨ???ˣ???????˼??==== My motherlanguage is Chinese , and I find chinese is more easy to study than English! If there are something troubled you, Please read My Chinese report instead.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 13 07:01:28 2024 UTC