php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21234 Cannot load "php4apache2.dll" into Apache 2.039
Submitted: 2002-12-27 23:32 UTC Modified: 2002-12-28 08:22 UTC
From: garyfung at adidacfellowship dot org Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.3.0 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: garyfung at adidacfellowship dot org
New email:
PHP Version: OS:

 

 [2002-12-27 23:32 UTC] garyfung at adidacfellowship dot org
Here's the error when I type: apache -k install

Syntax error on line 173 of D:/FoxServ/Apache/conf/httpd.conf:
Cannot load D:/FoxServ/php/sapi/php4apache2.dll into server: The specified procedure could not be found.

I disabled loading any optional PHP modules. PHP 4.23 worked with the exact same setup.

I tried using php4apache2.dll from PHP 4.23, Apache and PHP loaded successfully. But when I load a php script using fopen(), Apache crashes, along with the computer.

I coppied php4ts.lib and php4ts.dll to the directory where php4apache2.dll is. Perhaps there are additional libraries PHP 4.3 need but 4.23 didn't.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-28 00:38 UTC] garyfung at adidacfellowship dot org
I tried to run a strace, but strace apparently doesn't work on Winxp (blank output).

Also note the error is "specifed procedure" not found. If I take out php4ts.dll then it says "specified module".

Is there an alternative to strace I can use on Winxp for tracing which file is missing?
 [2002-12-28 00:51 UTC] moriyoshi@php.net
Are you sure that all the installed dlls (perhaps in the windows system directory) are updated by those bundled in 4.3.0? And did you try the latest version of Apache2 (2.0.43)?


 [2002-12-28 06:12 UTC] garyfung at adidacfellowship dot org
Thanks, Apache 2.0.43 worked. A sidenote: php4apache2.dll from PHP 4.3 doesn't work with Apache 2.0.39, but works with 2.0.43, which is also the only Apache version that works PHP 4.3 I believe.

Although support for Apache 2 is experimental, there should perhaps be some warning in the PHP 4.3 release re: which version of Apache works and which doesn't?
 [2002-12-28 08:22 UTC] moriyoshi@php.net
In this case, the error "specified procedure could not be found" was caused by the numerous Apache API change between 2.0.39 and 2.0.43. As it's all up to Apache, we are hardly able to have a note on this.

Thank you for the report.
 [2003-01-14 02:17 UTC] pbearpro at jcom dot home dot ne dot jp
I have installed Apache 2.0.43 and the latest stable PHP to date PHP 4.3.1-dev but I am still getting the error:

Cannot load C:/php/sapi/php4apache2.dll into server: Cannot find Unspecified Procedure

I have moved php4ts.lib to my system32 directory and my httpd.conf file is:

LoadModule php4_module c:/PHP/sapi/php4apache2.dll

I have edited the php.ini-recommended file and moved it to my winnt directory.

Have I done something wrong? or left something out?

Thank you for your help.

Shirokuma
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 09 06:03:45 2022 UTC