|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21229 Won't compile with roxen options
Submitted: 2002-12-27 19:40 UTC Modified: 2002-12-28 12:03 UTC
From: snyggve at canit dot se Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.3.0 OS: Debian 2.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
37 - 5 = ?
Subscribe to this entry?

 [2002-12-27 19:40 UTC] snyggve at canit dot se
./configure --with-roxen=/usr/local/roxen/server

compiled 4.2.3 yesterday, install worked great. Had to 
upgrade to 4.3.0 because of the setcookie() bug.

configure runs perfectly, in the end of the make-procedure, 
it quits. Wont make install either.

roxen.c -o sapi/roxen/roxen.lo 
/php-4.3.0/sapi/roxen/roxen.c: In function 
/php-4.3.0/sapi/roxen/roxen.c:476: too few arguments to 
function `php_module_startup'
make: *** [sapi/roxen/roxen.lo] Error 1
mactorget:/php-4.3.0# cd /usr/local/roxen/server/

Me -> :(



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-28 00:59 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.

 [2002-12-28 11:43 UTC] snyggve at canit dot se
Well, still compiling trouble :(

/bin/sh libtool --silent --mode=compile gcc  -Isapi/roxen/ 
-I/php4-STABLE-200212281630/sapi/roxen/ -DPHP_ATOM_INC -I/
php4-STABLE-200212281630/include -I/php4-STABLE-
200212281630/main -I/php4-STABLE-200212281630 -I/usr/local/
pike/7.0.352/include/pike -I/php4-STABLE-200212281630/Zend 
-I/php4-STABLE-200212281630/ext/xml/expat  -I/php4-STABLE-
200212281630/TSRM  -g -O2  -prefer-pic -c /php4-STABLE-
200212281630/sapi/roxen/roxen.c -o sapi/roxen/roxen.lo 
/php4-STABLE-200212281630/sapi/roxen/roxen.c: In function 
/php4-STABLE-200212281630/sapi/roxen/roxen.c:476: too few 
arguments to function `php_module_startup'
make: *** [sapi/roxen/roxen.lo] Error 1

Me still -> :(
 [2002-12-28 11:52 UTC]
The fix was added to the unstable 4.4.0-dev version, try that.
 [2002-12-28 12:03 UTC] snyggve at canit dot se
Ok, 4.4 cvs worked, but everything else failed :( so, im 
reverting to 4.2.3 for the moment

everything else = pages wont load on the homepage (a 
connection error occured) static pages worked though!

PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Dec 06 03:01:27 2023 UTC