php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21193 fsockopen timeout does not work
Submitted: 2002-12-26 07:28 UTC Modified: 2002-12-26 09:34 UTC
From: odarcan at hotmail dot com Assigned:
Status: Closed Package: Sockets related
PHP Version: 4.2.3 OS: not interesting
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: odarcan at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-12-26 07:28 UTC] odarcan at hotmail dot com
Hi, this problem has been reported SEVERAL times here but they have almost always been closed because of no feedback

there's also this big problem with fsockopen, it hangs.. while it hangs the timeout doesn't work.. and neither does the php script timeout.. if the php script timout worked.. the fsockopen hanging wouldnt be a very big problem (for me) since the script exection would stop.. but just so that you know:

i'm using php 4.2.3 and since the last 1-2 years, the fsockopen has hanged the script, and for the last year (1-2) the timeout has not been working either.

it is now December 26, 2002 and the both the hanging and infunctional timeout still haunts me today.

i have used several versions of php (4.0.6(?)-4.2.3) and several computers (mostly windows xp, but i think the problem exists on linux as well), and the hanging has been around all the time.

and today before i even write code that involves fsockopen, i start considering every other option so that i dont have to write a program that i know will be crippled from birth.

thank you for your time,
Osman Darcan

look at:
http://bugs.php.net/bug.php?id=10765
http://bugs.php.net/bug.php?id=7420
http://bugs.php.net/bug.php?id=12360

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-26 09:34 UTC] wez@php.net
Duplicate of 12360, which we fixed the other day.
If you can reproduce this problem with the latest stable snapshot from http://snaps.php.net, please re-open this report.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Aug 14 09:05:44 2022 UTC