php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21116 Where do I find PECL dlls?
Submitted: 2002-12-20 11:38 UTC Modified: 2003-05-13 18:34 UTC
From: chrisz at omti dot net Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.3.0 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chrisz at omti dot net
New email:
PHP Version: OS:

 

 [2002-12-20 11:38 UTC] chrisz at omti dot net
In the ini file there is a php_printer.dll option under extensions. No such dll file exists in the extensions directory. This option just needs to be deleted out of the ini file.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-20 12:04 UTC] philip@php.net
I'm not sure the policy of php.ini and extensions that aren't included in the windows distro (dlls) but regardless this is a php-dev question so am marking it as such.  I don't think the php.ini entry should be removed though, I'm sure there are others and they are commented out.   Also, this may have to do with PECL extensions being included or not.

Btw, you can find this (and many other dlls) here:
http://kromann.info/php4.php

Changing summary to: "Where do I find optional dlls?" :)
 [2002-12-20 12:15 UTC] chrisz at omti dot net
I understand. I just wanted to point out the fact that it isn't there. The dll needs to be packaged in the binary rather than having to go look for it. Thanks for the info.
 [2002-12-21 12:13 UTC] iliaa@php.net
printer extension had proved to be unstable and therefor was dropped from PHP core and moved to PECL. PECL extensions are NOT bundled by default. The documentation for the extension should be either moved to the PECL documentation repository or have a clear inidicator regarding the fact that it was moved to PECL.
 [2002-12-29 23:19 UTC] philip@php.net
Btw, I hear the good folks at PEAR are working on creating dll's for PECL extensions so that's where they'll be in the near future :)  Am marking this as a PEAR bug which can be closed when windows users can be told where to get them.  This information should be mentioned here:

http://pear.php.net/manual/en/pecl.php

Also, the windows pear faq may want to include more information on this topic including information about pear.bat and if pear is included in win binaries.  

New title: Where do I find PECL dlls?
 [2003-04-26 18:24 UTC] philip@php.net
It appears Frank now creates PECL dll's, is this the official place for windows users to get these or is there another?

http://kromann.info/pear-pecl.php
 [2003-04-28 12:06 UTC] wez@php.net
http://snaps.php.net/win32/PECL_4_3

holds some (not all!) PECL dlls, built with the official snapshot machine for win32.

 [2003-05-13 18:34 UTC] edink@php.net
The issue is fixed.

Click on the PECL icon on http://snaps.php.net/
 [2004-03-29 06:07 UTC] ash at bigfoot dot de
PECL php_zip.dll not in PHP5 RC1 anymore

Hello,

first of all thanks for providing the windows dlls!

Unfortunately the php_zip.dll was not included in the PHP 5.0.0RC1 release anymore, but it was in PHP 5.0.0 Beta 4.

http://www.php.net/downloads.php#v5
Collection of PECL modules for PHP 5.0.0RC1 [407Kb] - 18 Mar 2004

Under
http://snaps.php.net/
I can't find a php_zip.dll that works with PHP 5.0.0RC1.


Kind regards!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 20 17:03:35 2021 UTC