|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21103 conflicting types for gdIOCtx when re-compiling php 4.2.3
Submitted: 2002-12-19 19:22 UTC Modified: 2002-12-19 19:23 UTC
From: cash at polarcom dot com Assigned:
Status: Closed Package: GD related
PHP Version: 4.2.3 OS: suse 8.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: cash at polarcom dot com
New email:
PHP Version: OS:


 [2002-12-19 19:22 UTC] cash at polarcom dot com
for base config before loading gd


both modified and unmodified gd-2.0.1 makefile.unix  
LIBS= -lgd -> libgd.a 
give the same result

2 different configre options, same result
./configure --with-apxs=/www/bin/apxs --with-mysql --with-gd=/usr/local/src/gd-2.0.1 --enable-gd-native-ttf --with-bz2 --with-zlib

./configure --with-apxs=/www/bin/apxs --with-mysql --with-gd=/usr/local/src/gd-2.0.1 --enable-gd-native-ttf --with-bz2 --with-zlib  --with-freetype-dir=/usr --enable-gd-imgstrttf --with-jpeg-dir=/usr --with-png-dir=/usr

configure works ok, doesn't give any errors,
but when I make:
>>Making all in gd
>>make[2]: Entering directory `/usr/local/src/php->>4.2.3/ext/gd'
>>make[3]: Entering directory `/usr/local/src/php->>4.2.3/ext/gd'
>>/bin/sh /usr/local/src/php-4.2.3/libtool --silent -->>mode=compile gcc  -I. -I/usr/local/src/php-4.2.3/ext/gd ->>I/usr/local/src/php-4.2.3/main -I/usr/local/src/php->>4.2.3 -I/www/include -I/usr/local/src/php-4.2.3/Zend ->>I/usr/local/src/php-4.2.3/ext/mysql/libmysql ->>I/usr/local/src/php-4.2.3/ext/xml/expat  -DLINUX=22 ->>DUSE_HSREGEX -DUSE_EXPAT -I/usr/local/src/php-4.2.3/TSRM ->>g -O2 -prefer-pic  -c gd.c
>>In file included from gd.c:36:
>>php_gd.h:69: warning: static declaration for >>`gdImageColorResolve' follows non-static
>>gd.c:92: conflicting types for `gdIOCtx'
>>/usr/include/gd_io.h:18: previous declaration of `gdIOCtx'
>>make[3]: *** [gd.lo] Error 1
>>make[3]: Leaving directory `/usr/local/src/php->>4.2.3/ext/gd'
>>make[2]: *** [all-recursive] Error 1
>>make[2]: Leaving directory `/usr/local/src/php->>4.2.3/ext/gd'
>>make[1]: *** [all-recursive] Error 1
>>make[1]: Leaving directory `/usr/local/src/php-4.2.3/ext'
>>make: *** [all-recursive] Error 1

*This is my first bug report so I am not shure what more I could give...  Feel free to e-mail me for more info or if you have anything you would like my to try!

If this is a proper bug and It gets fixed THANK YOU VERY MUCH!!!!!!!!!


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-19 19:23 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jun 03 02:03:41 2023 UTC