php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21091 undefined reference to `ssl_onceonlyinit'
Submitted: 2002-12-18 23:17 UTC Modified: 2003-04-25 10:59 UTC
Votes:7
Avg. Score:4.6 ± 0.7
Reproduced:7 of 7 (100.0%)
Same Version:3 (42.9%)
Same OS:1 (14.3%)
From: jon at jellybob dot co dot uk Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.3.0RC3 OS: Debian Woody
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jon at jellybob dot co dot uk
New email:
PHP Version: OS:

 

 [2002-12-18 23:17 UTC] jon at jellybob dot co dot uk
Configuring PHP with:

./configure --prefix=/usr --sysconfdir=/etc --with-apxs2 --with-config-file-path=/etc --with-pear=/usr/share/pear --with-openssl --with-zlib --with-bz2 --with-dom --with-dom-xslt --enable-exif --enable-ftp --with-gd --with-gettext --with-iconv --with-imap --with-imap-ssl --with-mcrypt --with-mysql --with-pcntl --with-pgsql --with-pspell --enable-trans-sid

The compilation fails when it tries to compile the IMAP support, complaining about:

ext/imap/php_imap.lo: In function `zm_startup_imap':
/home/users/jon/src/php4/ext/imap/php_imap.c:424: undefined reference to `ssl_onceonlyinit'
collect2: ld returned 1 exit status

I have installed the version of c-client using apt-get, so I assume I'm using a fairly recent version of c-client.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-18 23:27 UTC] jon at jellybob dot co dot uk
Configuring PHP with:

./configure --prefix=/usr --sysconfdir=/etc --with-apxs2
--with-config-file-path=/etc --with-pear=/usr/share/pear --with-openssl
--with-zlib --with-bz2 --with-dom --with-dom-xslt --enable-exif
--enable-ftp --with-gd --with-gettext --with-iconv --with-imap
--with-imap-ssl --with-mcrypt --with-mysql --with-pcntl --with-pgsql
--with-pspell --enable-trans-sid

The compilation fails when it tries to compile the IMAP support,
complaining about:

ext/imap/php_imap.lo: In function `zm_startup_imap':
/home/users/jon/src/php4/ext/imap/php_imap.c:424: undefined reference to
`ssl_onceonlyinit'
collect2: ld returned 1 exit status

I can get it to compile by going into the file and commenting out that line, but I don't know what effect that's going to have on stability.
 [2003-01-31 13:48 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-04-20 19:55 UTC] aitrus at tresgeek dot net
The snapshot provided did not fix the bug.

Compiling on a Red Hat 9 box fails with:

ext/imap/php_imap.o(.text+0x463): In function `zm_startup_imap':
/usr/src/Apachetoolbox-1.5.64/src/php-snap/ext/imap/php_imap.c:428: undefined reference to `auth_gss'
ext/imap/php_imap.o(.text+0x46d):/usr/src/Apachetoolbox-1.5.64/src/php-snap/ext/
imap/php_imap.c:432: undefined reference to `ssl_onceonlyinit'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

The following configure options were used:

CPPFLAGS=-I/usr/local/include
LDFLAGS=-L/usr/local/lib
./configure --prefix=/usr/local \
--with-apache=/usr/src/Apachetoolbox-1.5.64/apache_1.3.27 \
--with-imap=/usr \
--with-imap-ssl=/usr \
--with-kerberos=/usr/kerberos \
--with-mhash=/usr/local \
--with-mcrypt=/usr/local \
--with-openssl=/usr \
--with-curl=/usr \
--with-gettext=/usr \
--with-mysql=/usr \
--with-ldap \
--with-xml \
--with-gd=shared,/usr \
--with-jpeg-dir=/usr \
--with-png-dir=/usr \
--with-zlib-dir=/usr \
--with-freetype-dir=/usr \
--with-pspell=/usr \
--with-bz2=/usr \
--enable-gd-native-ttf \
--enable-calendar \
--enable-exif \
--enable-track-vars \
--enable-magic-quotes \
--enable-trans-sid \
--enable-wddx \
--enable-ftp \
--enable-inline-optimization \
--enable-memory-limit \
--enable-sysvshm \
--enable-force-cgi-redirect \
--enable-safe-mode
 [2003-04-20 21:14 UTC] jellybob@php.net
Do you have c-client installed?

4.3.1 isn't giving out that error on compilation anymore using c-client 2001.
 [2003-04-23 10:11 UTC] bmansion at mamasam dot com
Same problem on Mandrake 9.1
 [2003-04-25 10:59 UTC] sniper@php.net
You just have c-client without ssl support with header files installed which have it. Not PHP bug.

 [2003-04-25 11:12 UTC] ryan at bubbagimp dot com
I am recieving this error in the latest ports on FreeBSD (php 4.3.1).  I do have c-client installed.
 [2003-05-01 10:47 UTC] jury at hightech dot lv
This is a bodus :)
in file "configure" doesn't check wether SSL support Enabled
Was This:
   int main() {
        ssl_onceonlyinit();
        return 0;
    }

Replace With:
   int main() {
        #ifdef HAVE_IMAP_SSL
        ssl_onceonlyinit();
        #endif
        return 0;
    }
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Feb 05 17:04:43 2023 UTC