php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21078 configure: error: not found. Please reinstall the expat distribution.
Submitted: 2002-12-18 08:55 UTC Modified: 2002-12-18 09:13 UTC
From: r_byrne at blackdogsoft dot net Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.3.0RC3 OS: redhat linux 8.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
41 - 36 = ?
Subscribe to this entry?

 
 [2002-12-18 08:55 UTC] r_byrne at blackdogsoft dot net
./configure --prefix=/apache/php/ --with-apache2 --with-apxs2=/apache/bin/apxs --with-dom --with-xmlrpc --enable-wddx --with-xml --with-dom --with-expat-dir=/usr/lib/ --enable-so --enable-tracking-vars


So, obviously I am configuring PHP to work with XML.  I have not yet tried the sablotron and the only bugs I have seen regarding expat are blamed on sablotron.  I keep getting the error:

configure: error: not found. Please reinstall the expat distribution.


I am new to linux and have been writing PHP on a junior level for a year and a half.  Any explanations are greatly appreciated.

Thanks in advance.
Robert Byrne

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-18 08:58 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

You need to spcify the root install dir for expat --with-expat-dir=/usr (but normally you wouldn't need to add this option at all).
 [2002-12-18 09:12 UTC] r_byrne at blackdogsoft dot net
I am sorry that I was not clearer with the 'bug' part.  expat is currently installed and being used by python and perl.  All the appropriate files are located in /usr/lib/ 
and it is telling me to reinstall.  I have reinstalled and installed 'expat-devel-1.95.4-1.i386.rpm' as well.  I have tried configuration with and without the development rpm.

Why isn't PHP seeing the expat libraries?  Is it looking for a different version?  Do I need to configure with a different compiler?

I'm sorry if this still doesn't qualify as a bug and if that is the case I will try the support site.  Sounds like PHP's not seeing expat where I have specified.

Thanks in advance.
Robert Byrne
 [2002-12-18 09:13 UTC] derick@php.net
Read my response again.
 [2014-01-22 19:05 UTC] faizal_pribadi at aol dot com
I Found This Solution If You Use Debian Or Ubuntu 

apt-get install libvarnishapi-dev

After this, re-install pecl varnish !
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 23:05:45 2022 UTC