php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21054 'ob_gzhandler' cannot be used twice???
Submitted: 2002-12-16 15:44 UTC Modified: 2003-01-12 11:57 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: busia at tiscali dot it Assigned:
Status: Closed Package: Output Control
PHP Version: 4.3.0RC3 OS: Redhat 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: busia at tiscali dot it
New email:
PHP Version: OS:

 

 [2002-12-16 15:44 UTC] busia at tiscali dot it
Sometimes (it seems random) I find in the error_log this fatal error:

PHP Warning:  (null)() [<a href='http://www.php.net/ref.outcontrol'>ref.outcontr
ol</a>]: output handler 'ob_gzhandler' cannot be used twice in Unknown on line 0

Repeated 4 times.

I haven't activated gz_handler in php.ini and it's not activated in virtaulhosts, I don't set in scripts. I'm not using it, why it tells me that I use it TWICE?

Andrea Busia

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-16 15:45 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-12-16 15:52 UTC] busia at tiscali dot it
I don't know if it's a particular script to cause the warning, the log don't tell me anything

Other informations:

Apache: 2.0.43
PHP: 4.3.0RC3
Zend Optimizer: 2.0.3

Configure:
'./configure' '--enable-track-vars' '--prefix=/usr' '--exec-prefix=/usr' '--libexecdir=/usr/lib/apache' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--datadir=/home/httpd' '--sysconfdir=/etc/httpd/conf' '--localstatedir=/var' '--libdir=/usr/lib/apache' '--includedir=/usr/include/apache' '--mandir=/usr/man' '--with-mysql=/usr' '--with-config-file-path=/usr/local/Zend/etc' '--enable-memory-limit' '--with-apxs2' '--with-zlib' '--disable-session'
 [2002-12-16 15:56 UTC] derick@php.net
It's a pretty useless bugreport like this. Suspended until you can profile some real useful information to reproduce this problem.
 [2002-12-18 04:45 UTC] ruslan_y at visit dot ru
The same message appears if I place 
<?php 
ob_start('ob_gzhandler');
?>
in the begining of the any php script.

(W2kPro SP2, PHP4.3.0RC2, Apache 2.0.43)
 [2003-01-11 11:41 UTC] helly@php.net
To both of you: please execute the following script:

<?php
$a=array();
function get($n) { global $a; $a[$n] = ini_get($n); }
get('output_buffering');
get('output_handler');
get('zlib.output_compression');
get('zlib.output_handler');
var_dump($a);
?>
 [2003-01-11 14:58 UTC] busia at tiscali dot it
Now I have 4.4.0-dev (200301041230) and the problem seems to be corrected, I don't see anymore this warning in logs.

BTW this is the output:
------------------------
array(4) { ["output_buffering"]=> string(1) "1" ["output_handler"]=> bool(false) ["zlib.output_compression"]=> string(0) "" ["zlib.output_handler"]=> string(0) "" } 
------------------------
 [2003-01-12 11:57 UTC] helly@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

So than it is fixed in CVS -> closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 28 19:01:31 2020 UTC