php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2100 Problems with ? : arrays and isset
Submitted: 1999-08-18 04:55 UTC Modified: 2002-06-16 08:37 UTC
From: drew at elysium dot ltd dot uk Assigned:
Status: Not a bug Package: Misbehaving function
PHP Version: 3.0.12 OS: Linux RH 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: drew at elysium dot ltd dot uk
New email:
PHP Version: OS:

 

 [1999-08-18 04:55 UTC] drew at elysium dot ltd dot uk
<?
$x = isSet($x) ? "Set" : "Not Set";
$y["x"] = isSet($y["x"]) ? "Set" : "Not Set";
if (isSet($z["x"]))
  $z["x"] = "Set";
else
  $z["x"] = "Not Set";

print "x = " . $x . "<BR>\n";
print "y[\"x\"] = " . $y["x"] . "<BR>\n";
print "z[\"x\"] = " . $z["x"] . "<BR>\n";
?>

$x gets set to "Not Set" - Correct
$y["x"] gets set to "Set" - Not Correct
$y["x"] gets set to "Not Set" - Correct

This problem does not happen in 4.0b2 only in 3.0.12 (and I suppose other versions of php3.0.x)

Rgds Drew

The variables is question have never been used before, as can be seen.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-11-11 19:54 UTC] joey at cvs dot php dot net
The problem may be in
$y["x"] = isSet($y["x"]) ? "Set" : "Not Set";

Maybe there is some kind of "look behind" being done?
This looks like a fun one! :)

 [2002-06-16 08:37 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue May 21 01:01:27 2019 UTC