|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20947 imap won't configure or compile
Submitted: 2002-12-11 15:56 UTC Modified: 2002-12-11 17:16 UTC
From: fm dot vogel at hccnet dot nl Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.3.0RC3 OS: linux slackware 8.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
32 - 29 = ?
Subscribe to this entry?

 [2002-12-11 15:56 UTC] fm dot vogel at hccnet dot nl
I have this problem with versions 4.2.3 and 4.30RC3,
didn't try any other.
I have searched the mailing lists and saw several messages with the same problem.
However, no messages with the solution...
My openssl version is 0.9.6h.
I have installed imap (imap-2002a.DEV.SNAP-0212051126) and copied the c-client files as stated in your documentation.

1. configured php with following configure:

/configure --with-apxs=/usr/local/apache/bin/apxs --with-config-file-path=/etc --with-mysql --with-mcrypt --with-openssl=/us
r/local/ssl --with-imap-ssl=/usr/local/lib

checking for IMAP support... no
After running make and make install and restarting apache (DSO module) tried to use imap:
Fatal error:  Call to undefined function:  imap_open() in /var/www/htdocs/tickets/imap_create.php on line 11

2. Tried without "with-imap-ssl", but with "--with-imap":

./configure --with-apxs=/usr/local/apache/bin/apxs --with-config-file-path=/etc --with-mysql --with-mcrypt --with-openssl=/u
sr/local/ssl --with-imap

configure: error: This c-client library is built with SSL support.

      Add --with-imap-ssl<=DIR> to your configure line. Check config.log for details.

So, the configure script is finding the c-client libraries.

Output from config.log:

/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:268: the use of `tmpnam' is dangerous, better use `mkstemp'
/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:281: undefined reference to `RAND_seed'
/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:286: undefined reference to `SSL_library_init'
/usr/local/lib/libc-client.a(osdep.o): In function `ssl_start_work':
/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:388: undefined reference to `TLSv1_client_method'
/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:388: undefined reference to `SSLv23_client_method'
/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:388: undefined reference to `SSL_CTX_new'
/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:391: undefined reference to `SSL_CTX_ctrl'
/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:395: undefined reference to `SSL_CTX_set_verify'
/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:397: undefined reference to `SSL_CTX_set_default_verify_paths'
/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:398: undefined reference to `SSL_new'
/install/imap-2002a.DEV.SNAP-0212051126/c-client/osdep.c:400: undefined reference to `BIO_new_socket'


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-11 17:16 UTC]
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Oct 05 15:05:52 2022 UTC