php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20892 PHP won't compile with latest ming from CVS
Submitted: 2002-12-08 20:51 UTC Modified: 2002-12-08 22:40 UTC
From: rolyv at bigpond dot com Assigned:
Status: Not a bug Package: Ming related
PHP Version: 4.3.0RC2 OS: Red Hat Linux 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rolyv at bigpond dot com
New email:
PHP Version: OS:

 

 [2002-12-08 20:51 UTC] rolyv at bigpond dot com
When trying to compile PHP with the latest version of ming from CVS, it gives these errors:

/usr/src/redhat/BUILD/php-4.3.0RC2/ext/ming/ming.c: In function `zif_swfmovie_output':
/usr/src/redhat/BUILD/php-4.3.0RC2/ext/ming/ming.c:1439: too few arguments to function `SWFMovie_output'
/usr/src/redhat/BUILD/php-4.3.0RC2/ext/ming/ming.c: In function `zif_swfmovie_saveToFile':
/usr/src/redhat/BUILD/php-4.3.0RC2/ext/ming/ming.c:1462: too few arguments to function `SWFMovie_output'
/usr/src/redhat/BUILD/php-4.3.0RC2/ext/ming/ming.c: In function `zif_swfmovie_save':
/usr/src/redhat/BUILD/php-4.3.0RC2/ext/ming/ming.c:1480: too few arguments to function `SWFMovie_output'
/usr/src/redhat/BUILD/php-4.3.0RC2/ext/ming/ming.c:1490: too few arguments to function `SWFMovie_output'
make: *** [ext/ming/ming.lo] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-08 22:13 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Apparently ming author(s) had changed their API in the CVS making it incompatible with the API php is used to. If this is  still an issue when the next ming release is made reopen the bug report.
 [2002-12-08 22:17 UTC] rolyv at bigpond dot com
Umm it is a bug in PHP, I am saying that when I set the dir in --with-ming to the CVS version of ming PHP wont compile (but it will when i set the dir to point to ming 0.2a)
 [2002-12-08 22:18 UTC] rolyv at bigpond dot com
Sorry, didn't see this bit:


Apparently ming author(s) had changed their API in the CVS making it
incompatible with the API php is used to. If this is  still an issue
when the next ming release is made reopen the bug report.

But why can't PHP be fixed to work with it?
 [2002-12-08 22:25 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Because at the moment it is not known whether the change that broke the API is permanent or not, for all we know it could change tommorow. Once a release in made and the API is solidified then it is time to make any changes if need be, not before.
 [2002-12-08 22:40 UTC] sniper@php.net
Use the released version of Ming..and notify the Ming authors that they have broken their API. :)

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 11:01:23 2020 UTC