php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20816 imagecopyresampled turn white into yellow
Submitted: 2002-12-04 13:24 UTC Modified: 2002-12-08 17:25 UTC
From: bill at softky dot com Assigned:
Status: Closed Package: GD related
PHP Version: 4.4.0-dev OS: WinXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bill at softky dot com
New email:
PHP Version: OS:

 

 [2002-12-04 13:24 UTC] bill at softky dot com
The function imagecopyresampled() takes a white area (255,255,255) and turns it yellow (255,255,2). This does not happen with imagecopyresize().  I think the problem is in the GD library, because the problem disappears when I use the php_gd2.dll from  PHP4.2.3 instead of the one that came bundled with 4.4.0-dev.

What phpinfo() says: 
"4.4.0-dev" (both broken and working cases)
"GD 2.0 (bundled)" BROKEN case
"GD 2.0 or higher" WORKING case

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-04 15:26 UTC] iliaa@php.net
Could you please show the complete script and if possible the source image you are using. So far, I was able to replicate the problem if I created the destination image using imagecreatetruecolor(). However, if I use imagecreate() it works correctly.
 [2002-12-04 18:10 UTC] sniper@php.net
restored the correct info..
 [2002-12-08 17:25 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jul 07 00:05:45 2022 UTC