php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #20758 php_value without value causes apache to crash
Submitted: 2002-12-02 04:20 UTC Modified: 2002-12-02 04:53 UTC
From: uhlar at fantomas dot sk Assigned:
Status: Not a bug Package: Feature/Change Request
PHP Version: 4.2.3 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: uhlar at fantomas dot sk
New email:
PHP Version: OS:

 

 [2002-12-02 04:20 UTC] uhlar at fantomas dot sk
i found out that if I pass
php_value mysql.default_password
without given password, it causes apache to crash

Of course, the input is incorrect, but it should be ignored probably (or used as empty) and should not cause apache to crash.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-02 04:27 UTC] derick@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
 [2002-12-02 04:37 UTC] uhlar at fantomas dot sk
Hopsa, maybe i usd wrong words. as 'crash' I meaned that apache exits:

[Mon Dec  2 08:40:21 2002] [notice] SIGHUP received. Attempting to restart
Syntax error on line 270 of /usr/local/etc/apache/httpd.conf: php_value takes two arguments, PHP Value Modifier

No core is dumped.
 [2002-12-02 04:44 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Not a bug, use:
php_value mysql.default_password none

Derick
 [2002-12-02 04:50 UTC] uhlar at fantomas dot sk
The reason why I asked is php not to exit if no password is given for any reason.

Let's say it different way - It would be nice if PHP would continue operations even if someone forgots to fill value.
The directive should be ignored in that case.
 [2002-12-02 04:53 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

It's not a PHP thing, but an Apache requirement.
Please leave the status to bogus, as it is not a bug.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 12:05:44 2022 UTC