|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20755 exif relocation error
Submitted: 2002-12-01 21:22 UTC Modified: 2002-12-21 09:46 UTC
From: oden dot eriksson at linux-mandrake dot com Assigned: helly (profile)
Status: Closed Package: mbstring related
PHP Version: 4.3.0RC2 OS: Mandrake 9.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: oden dot eriksson at linux-mandrake dot com
New email:
PHP Version: OS:


 [2002-12-01 21:22 UTC] oden dot eriksson at linux-mandrake dot com
apache2 CVS-20021202

Here's my configure line:

#export MYFLAGS="-O3 -fomit-frame-pointer -pipe  -march=`uname -m` -mcpu=`uname -m` -ffast-math -fno-strength-reduce"
export LIBS="-lttf -lfreetype -lpng -ljpeg -lz -lnsl"
export EXTENSION_DIR="/usr/local/php4/lib/php/extensions"
export IMAP_SHARED_LIBADD="-lc-client -lssl -lcrypto"
#export READLINE_SHARED_LIBADD="-lreadline"
export PROG_SENDMAIL="/var/qmail/bin/usendmail"
#export WANT_AUTOCONF_2_5="1"

if ! [ -f ./configure ]; then ./buildconf; fi

#exit 1

#make distclean

./configure \
--prefix=/usr/local/php4 \
--sysconfdir=/etc \
--with-apxs2=/usr/sbin/apxs \
--with-layout=GNU \
--with-config-file-path=/etc/httpd/conf \
--with-openssl=shared,/usr \
--enable-magic-quotes \
--disable-rpath \
--enable-force-cgi-redirect \
--disable-debug \
--enable-pic \
--enable-inline-optimization \
--with-zlib \
--without-aspell \
--with-bz2=shared,/usr \
--enable-calendar=shared \
--with-jpeg-dir=shared,/usr \
--with-tiff-dir=shared,/usr \
--with-curl=shared,/usr \
--enable-dba=shared,/usr \
--with-gdbm=shared,/usr \
--with-db3=shared,/usr \
--with-db4=shared,/usr \
--with-cdb=shared,/usr \
--with-flatfile=shared \
--enable-dbx=shared,/usr \
--enable-dio=shared,/usr \
--with-dom=shared,/usr \
--with-dom-xslt=shared,/usr \
--with-dom-exslt=shared,/usr \
--enable-ftp \
--with-gd=shared \
--with-jpeg-dir=shared,/usr \
--with-png-dir=shared,/usr \
--with-ttf=shared,/usr \
--with-freetype-dir=shared,/usr \
--with-t1lib=shared,/usr \
--enable-gd-native-ttf \
--with-gettext=shared,/usr \
--with-gmp=shared,/usr \
--with-imap=shared,/usr \
--with-imap-ssl=shared,/usr \
--with-ldap=shared,/usr \
--with-mcrypt=shared,/usr \
--with-mhash=shared,/usr \
--enable-mime_magic=shared,/usr \
--with-ming=shared,/usr \
--with-mysql=shared,/usr \
--with-unixODBC=shared,/usr \
--with-jpeg-dir=shared,/usr \
--with-png-dir=shared,/usr \
--with-tiff-dir=shared,/usr \
--with-pgsql=shared,/usr \
--with-pspell=shared,/usr \
--with-recode=shared,/usr \
--with-snmp=shared,/usr \
--enable-ucd-snmp-hack \
--enable-sockets=shared \
--with-regex=system \
--enable-sysvmsg \
--enable-sysvsem \
--enable-sysvshm \
--enable-wddx=shared \
--with-xmlrpc=shared,/usr \
--enable-xslt=shared,/usr \
--with-xslt-sablot=shared,/usr \
--enable-yp \
--with-zip=shared,/usr \
--with-xpm-dir=shared,/usr/X11R6/lib/ \
--enable-mbstring=shared \
--enable-mbregex=shared \
--enable-exif=shared \
--enable-overload=shared \
--enable-tokenizer=shared \
--enable-mime-magic=shared \

#--with-dbm=shared,/usr \
#--with-vpopmail=shared,/home/vpopmail \
#--with-xpm-dir=shared,/usr \
#--with-pcre-regex=shared,/usr \
#--with-qtdom=shared,/usr \
#--with-expat-dir=shared,/usr \
#--with-readline=shared,/usr \

And here's the error:

/usr/local/php4/bin/php: relocation error: /usr/local/php4/lib/php/extensions/ undefined symbol: php_mb_check_encoding_list


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-01 21:31 UTC]
If you compile mbstring as static module, you can workaround this error. It's not very good idea to enable it anyway..

For the mbstring authors: You should decide whether or not to allow external usage of these functions (ie. in other extensions) or disable the building of this extension as shared altogether..
 [2002-12-01 21:33 UTC]
And btw. you shouldn't try outsmarting the configure with all those LIBS/CFLAGS you're defining before running configure..

And read the 'configure --help' sometimes. Some configuration options DO NOT SUPPORT 'shared' at all.
(like --with-xpm-dir)

Building anything as shared is pretty much asking for trouble, just build what you need and don't use the shared modules.

 [2002-12-01 22:10 UTC] oden dot eriksson at linux-mandrake dot com
What a fast reply!

I have fixed my configure line now, but when I tried to enable readline support I got:

checking for readline in -lreadline... no
configure: error: readline library not found

Gotta continue with this tomorrow.
 [2002-12-03 07:12 UTC] oden dot eriksson at linux-mandrake dot com
readline still wasn't found so I had to disable it. I was not able to build zlib as a shared module.

Here's my new configure line:

'./configure' '--prefix=/usr/local/php4' '--sysconfdir=/etc' '--with-apxs2=/usr/sbin/apxs' '--with-layout=GNU' '--with-config-file-path=/etc/httpd/conf' '--with-openssl=shared,/usr' '--enable-magic-quotes' '--disable-rpath' '--enable-force-cgi-redirect' '--disable-debug' '--enable-pic' '--enable-inline-optimization' '--with-zlib' '--without-aspell' '--with-bz2=shared,/usr' '--enable-calendar=shared' '--with-jpeg-dir=shared,/usr' '--with-tiff-dir=shared,/usr' '--with-curl=shared,/usr' '--enable-dba=shared,/usr' '--with-gdbm=shared,/usr' '--with-db3=shared,/usr' '--with-db4=shared,/usr' '--with-cdb=shared,/usr' '--with-flatfile=shared' '--enable-dbx=shared,/usr' '--enable-dio=shared,/usr' '--with-dom=shared,/usr' '--with-dom-xslt=shared,/usr' '--with-dom-exslt=shared,/usr' '--enable-ftp=shared' '--with-gd=shared' '--with-jpeg-dir=shared,/usr' '--with-png-dir=shared,/usr' '--with-ttf=shared,/usr' '--with-freetype-dir=shared,/usr' '--with-t1lib=shared,/usr' '--enable-gd-native-ttf' '--with-gettext=shared,/usr' '--with-gmp=shared,/usr' '--with-imap=shared,/usr' '--with-imap-ssl=shared,/usr' '--with-ldap=shared,/usr' '--with-mcrypt=shared,/usr' '--with-mhash=shared,/usr' '--enable-mime_magic=shared,/usr' '--with-ming=shared,/usr' '--with-mysql=shared,/usr' '--with-unixODBC=shared,/usr' '--with-jpeg-dir=shared,/usr' '--with-png-dir=shared,/usr' '--with-tiff-dir=shared,/usr' '--with-pgsql=shared,/usr' '--with-pspell=shared,/usr' '--with-recode=shared,/usr' '--with-snmp=shared,/usr' '--enable-ucd-snmp-hack' '--enable-sockets=shared' '--with-regex=system' '--enable-sysvmsg=shared' '--enable-sysvsem=shared' '--enable-sysvshm=shared' '--enable-wddx=shared' '--with-xmlrpc=shared,/usr' '--enable-xslt=shared,/usr' '--with-xslt-sablot=shared,/usr' '--enable-yp=shared' '--with-zip=shared,/usr' '--with-xpm-dir=/usr/X11R6/lib/' '--enable-mbregex=shared' '--enable-overload=shared' '--enable-tokenizer=shared' '--enable-ctype=shared' '--enable-mime-magic=shared' '--enable-shared'

I ran make test and let it send the test by e-mail.
 [2002-12-14 23:51 UTC]
Please try using this CVS snapshot:
For Windows:

 [2002-12-21 09:46 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 05:01:29 2024 UTC