php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20724 Can't read body information.
Submitted: 2002-11-29 08:12 UTC Modified: 2002-11-29 08:40 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: michael at bested dot net Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.2.3 OS: Win2k
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: michael at bested dot net
New email:
PHP Version: OS:

 

 [2002-11-29 08:12 UTC] michael at bested dot net
First, I try to connect to my mail server with POP3 and read a mail:

     $Con = imap_open("{localhost:110/pop3}", "user", "pass");
     print imap_body ($Con, "1", FT_UID);

No problem!

Then I try:

     $Con = imap_open("{localhost:143}", "user", "pass");
     print imap_body ($Con, "1", FT_UID);

then the script return: no body information available.


I have no problems reading the header information or using imap_fetch_overview();

Can it be a bug?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-29 08:18 UTC] michael at bested dot net
print imap_body ($Con, "1", FT_UID);

The "1" if the UID of the message.
 [2002-11-29 08:39 UTC] sniper@php.net
Is there a message with UID 1? 
 [2002-11-29 08:40 UTC] sniper@php.net
On second though, this can't be any bug in PHP since we only wrap around the c-client library..most likely user error too, ask support elsewhere.
 [2002-11-30 05:45 UTC] michael at bested dot net
http://indbrudstyv.dk/mail/mail.php

Try to check this example.

First, I connect with POP3 - no problem. Then I connect with IMAP but don't get the body.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 14:05:44 2022 UTC