php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20718 PHP did not use php.ini
Submitted: 2002-11-29 05:33 UTC Modified: 2002-11-29 06:27 UTC
From: htobias at stc-kg dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.3.0RC2 OS: Suse Linux 8.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: htobias at stc-kg dot com
New email:
PHP Version: OS:

 

 [2002-11-29 05:33 UTC] htobias at stc-kg dot com
Hi There!

My configuration:

Suse Linux 8.1
Apache 2
PHP 4.3.0RC2 (also tested with the last Stable)

Compile-Options:

./configure --with-mysql --with-apxs2=/usr/sbin/apxs  --with-openssl --disable-debug --with-config-file-path=/etc/httpd

php.ini:

/etc/httpd>
-rw-r--r--    1 root     root        25549 2002-11-29 11:25 php.ini

I have changed some settings in php.ini, such as

safe_mode = On
open_basedir = "/dir"
register_globals = On

When I call phpinfo:

Configuration File (php.ini) Path  /etc/httpd
safe_mode= Off
open_basedir = no value
register_globals = Off

I than have tried to compile without "with-config-file-path" and but the php.ini in "/usr/local/lib" (as shown in phpinfo).
Same problem.
And sure, I have restarted apache and the hole system ;)

This is since I have updated from 4.2.3.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-29 06:27 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 22:05:43 2022 UTC