php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #20690 fopen should check with uploaded_file not only open_basedir
Submitted: 2002-11-27 20:57 UTC Modified: 2015-02-20 15:14 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: xuefer at 21cn dot com Assigned: krakjoe (profile)
Status: Closed Package: Safe Mode/open_basedir
PHP Version: * OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
31 + 22 = ?
Subscribe to this entry?

 
 [2002-11-27 20:57 UTC] xuefer at 21cn dot com
(feature request)
in restrict mode, php check fopen() file with uploaded_file when it's not in open_basedir
by now, i have to move_uploaded_file() to my {open_basedir}/tmp, read it, and delete it in shutdown_function.

i know, we can config php to use stand alone uploadtmp instead of /tmp, and add it to open_basedir, e.g.: /www/tmp
but would'nt it nice to check with uploaded_file ?
:)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-01-01 20:28 UTC] jani@php.net
-Package: Feature/Change Request +Package: Safe Mode/open_basedir -Operating System: all +Operating System: * -PHP Version: 4.2.3 +PHP Version: *
 [2015-02-20 15:14 UTC] krakjoe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: krakjoe
 [2015-02-20 15:14 UTC] krakjoe@php.net
Since safe mode has been removed, this bug can be put to bed.

This report can still be found for reference, sorry about the wait :)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 15:01:27 2020 UTC