php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20669 DomDocument->create_element_ns undefined
Submitted: 2002-11-27 03:00 UTC Modified: 2002-11-27 05:15 UTC
From: hfuecks at phppatterns dot com Assigned:
Status: Not a bug Package: DOM XML related
PHP Version: 4.2.3 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hfuecks at phppatterns dot com
New email:
PHP Version: OS:

 

 [2002-11-27 03:00 UTC] hfuecks at phppatterns dot com
Using;
libxml Version
2.4.21

HTML Support
enabled

XPath Support
enabled

XPointer Support
enabled

The following results in "call to undefined function";

<?php
$dom=domxml_new_doc('1.0');
$root=$dom->create_element_ns('http://www.php.net','domxml','php');
$root=$dom->append_child($root);
?>

Using create_element though causes no problems;

<?php
$dom=domxml_new_doc('1.0');
$root=$dom->create_element('domxml');
$root=$dom->append_child($root);
?>

[Looked hard but found no other bug listed with reference to create_element_ns in the DOM extension]

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-27 05:15 UTC] chregu@php.net
DomDocument->create_element_ns will only be available since PHP 4.3. Download it from http://snaps.php.net/ or wait until it is officially released

chregu
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Nov 11 22:01:32 2019 UTC