php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20469 Different files...
Submitted: 2002-11-17 16:41 UTC Modified: 2002-11-17 18:17 UTC
From: delgadoj at deltechlabs dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.2.3 OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: delgadoj at deltechlabs dot com
New email:
PHP Version: OS:

 

 [2002-11-17 16:41 UTC] delgadoj at deltechlabs dot com
Ok. Heres the run down. After you install PHP, you have the 2 php.ini files. One in c:\windows(or winnt) and one in the C:\php\backup folder. Apprarently the PHP.inis are different. The working copy has its Error_reporting setting set to E_ALL. That causes some scripts to fail because the NOTICES begin to show, which causes the script to fail. The Backup copy has the setting set correctly at E_ALL & ~E_NOTICE. This setting allows the scripts to run correctly. This is just to let you know.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-17 18:17 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

It seems your original php.ini was backed up and a new one copied during the install. The new php.ini configurations set error reporting to E_ALL so, if you don't want to see notices simply change the error reporting to the previous E_ALL & ~E_NOTICE.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 09 18:03:50 2022 UTC