php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20450 Acquisition of 2 vars with GET works not fine
Submitted: 2002-11-15 14:18 UTC Modified: 2002-11-15 16:13 UTC
From: freepol at free dot fr Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 4.2.3 OS: MacOsX.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: freepol at free dot fr
New email:
PHP Version: OS:

 

 [2002-11-15 14:18 UTC] freepol at free dot fr
I try to invoke with the URL 
http://192.168.0.4/~paul/test1.php?toto=ert+tutu=aze
the following  PHP script :
<head>
<title>Liste des arguments</title>
</head>
<body BGCOLOR="cyan">
<?php echo "Ceci est un pg PHP<br>";
 echo phpinfo() ;
 ?>
</body>
</html>
Bad surprise i find in the tables :
_GET["toto"]	has value "ert tutu=aze"?
that is *NOT* good ! But in a line underneath we have:
_SERVER["argv"] has value	Array ( [0] => toto=ert
                                  [1] => tutu=aze )
with argc pointing on the value 2.
That is *VERY* good for the GET method.

I have find nothing in the bug reports related to the word 
GET. So i post this message.
Yours 
PAUL DELANNOY
http://tontonpol.dyndns.org

PHP : System	Darwin primavera.entropy.ch 6.1 Darwin Kernel 
Version 6.1: Fri Sep 6 23:24:34 PDT 2002; 
root:xnu/xnu-344.2.obj~2/RELEASE_PPC Power Macintosh 
powerpc
Build Date	Sep 24 2002 23:15:03
Configure Command	'./configure' '--disable-cli' 
'--with-apxs' '--with-mysql' '--with-pgsql' 
'--with-gd=/usr/local' '--with-png-dir=/usr/local' 
'--with-zlib-dir=/usr' '--with-jpeg-dir=/usr/local' 
'--with-freetype-dir=/usr/local' '--with-t1lib=/usr/local' 
'--enable-trans-sid' '--enable-exif' '--with-xml' 
'--enable-wddx' '--with-curl=/usr/local' 
'--with-pdflib=/usr/local' '--enable-ftp' 
'--enable-mbstring' '--enable-xslt' 
'--with-xslt-sablot=/usr/local' '--with-imap=../imap-2001a' 
'--enable-dbx' '--enable-dbase' '--with-mcrypt=/usr/local' 
'--enable-sockets' '--with-ldap' '--with-xmlrpc' 
'--with-iodbc'
Server API	Apache
Virtual Directory Support	disabled
Configuration File (php.ini) Path	/usr/local/lib
Debug Build	no
Thread Safety	disabled

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-15 14:20 UTC] moriyoshi@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip
 [2002-11-15 16:13 UTC] freepol at free dot fr
Hi, it's not a bug : only a bad delimitor (it's must be & and i use +) Thank you, Nicolas.
See you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 16:01:23 2020 UTC