php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20430 Missing libs for Solaris sybase-ct compile
Submitted: 2002-11-14 11:17 UTC Modified: 2003-01-02 18:39 UTC
From: scampbel at jamedia dot com Assigned:
Status: No Feedback Package: Sybase-ct (ctlib) related
PHP Version: 4.3.0-pre2 OS: SunOS 5.8
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: scampbel at jamedia dot com
New email:
PHP Version: OS:

 

 [2002-11-14 11:17 UTC] scampbel at jamedia dot com
When PHP is configured for Sybase-CT support, it configures correctly except that it doesn't include libtli.so, which is necessary for Solaris.

For details, check:

http://www.sybase.com/detail/1,6904,1011596,00.html

If I edit Makefile and change -linsck to -ltli the configuration works fine.

If I don't, sybase-ct will come back with an error saying it doesn't have network transport layer to its $DSQUERY host. All other networking configurations have been done on this box. In fact the Sybase ASE dataserver is on the same box...

General environment summary:

uname -a output:
SunOS thoddb001 5.8 Generic_108528-15 sun4u sparc SUNW,Ultra-60

using gcc-2.95.3 to build php-4.2.3-RELEASE

configuration flags for php & sybase-ct support

env LDFLAGS=" -R $SYBASE/$SYBASE_OCS/lib -R /usr/local/lib " ./configure --prefix=/local/php-4.2.3 --with-apxs2=/local/apache_2_0_43/bin/apxs --with-config-file-path=/local/php4/lib --without-pear --without-mysql --with-pdflib=/usr/local --with-sybase-ct=$SYBASE/$SYBASE_OCS

The configuration has been tried without the /usr/local/lib path and PDF support disabled.

PHP code which demonstrates the problem:

$query = "BEGIN ";
$query .= "declare @return_status INTEGER ";
$query .= " execute @return_status = spGetSession ";
$query .= " @pUser_ID = '$USER_ID, ', ";
$query .= " @pSEQ_ID = '$SEQ_ID, ', ";
$query .= " @pFunction_ID = $FUNCID ";
$query .= " select @return_status as return_status ";
$query .= " END ";

$jnamedia_conn = sybase_pconnect($JNAMEDIA, $DATABASE_USER_ID, $DATABASE_PASSWORD) or die("Connect to $JNAMEDIA error.");

$result = sybase_query($query, $jnamedia_conn) or die("Check_session error. Query was $query");

$row = sybase_fetch_array($result);

$ret_val = $row["return_status"];

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-14 11:20 UTC] scampbel at jamedia dot com
In my post, I wrote that I configured php-4.2.3.

I have in fact tried php-4.2.3, and php4-STABLE-2002111416

with the same results.
 [2002-12-07 16:04 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2003-01-02 18:39 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 21:01:27 2024 UTC