php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20414 Sysbase_ct extensions did not work in php-4.3.0
Submitted: 2002-11-13 12:20 UTC Modified: 2002-11-14 14:05 UTC
From: alietss at yahoo dot com Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4CVS-2002-11-13 OS: Linux RedHat8.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: alietss at yahoo dot com
New email:
PHP Version: OS:

 

 [2002-11-13 12:20 UTC] alietss at yahoo dot com
Hi all the php developers, Im testing php-4.3.0 in RedHat8.0, httpd-2.0.40 from redhat packages, I'm using sybase_ct support trought freetds, here is my configure script...

%configure \
	--prefix=%{_prefix} \
	--with-config-file-path=%{_sysconfdir} \
	--enable-force-cgi-redirect \
	--disable-debug \
	--enable-pic \
	--disable-rpath \
	--enable-inline-optimization \
	--with-bz2 \
	--with-db3 \
	--with-curl \
	--with-dom=%{_prefix} \
	--with-exec-dir=%{_bindir} \
	--with-freetype-dir=%{_prefix} \
	--with-png-dir=%{_prefix} \
	--with-gd \
	--enable-gd-native-ttf \
	--with-ttf \
	--with-gdbm \
	--with-gettext \
	--with-pdflib=shared \
	--with-tiff-dir=%{_prefix} \
	--with-ncurses \
	--with-gmp \
	--with-iconv \
	--enable-xslt=shared \
	--with-jpeg-dir=%{_prefix} \
	--with-openssl \
	--with-png \
	--with-pspell \
	--with-regex=system \
	--with-xml \
	--with-expat-dir=%{_prefix} \
	--with-zlib \
	--with-layout=GNU \
	--enable-bcmath \
	--enable-exif \
	--enable-ftp \
	--enable-magic-quotes \
	--enable-safe-mode \
	--enable-sockets \
	--enable-sysvsem \
	--enable-sysvshm \
	--enable-discard-path \
	--enable-track-vars \
	--enable-trans-sid \
	--enable-yp \
	--enable-wddx \
	--without-oci8 \
	--with-pear=/usr/share/pear \
	--with-imap=shared \
	--with-imap-ssl \
	--with-kerberos=/usr/kerberos \
	--with-ldap=shared \
	--with-mcal=shared,%{_prefix} \
	--with-mcrypt=shared,%{_prefix} \
	--with-mhash=shared,%{_prefix} \
	--with-mysql=shared,%{_prefix} \
%if %{oracle}
	--with-oci8=shared \
%endif
	--with-pgsql=shared \
	--with-snmp=shared,%{_prefix} \
	--with-snmp=shared \
	--with-sybase-ct=shared,%{_prefix} \
	--with-xslt-sablot=shared,%{_prefix} \
	--with-sablot-js=shared,%{_prefix} \
	--enable-ucd-snmp-hack \
	--with-unixODBC=shared \
	--enable-memory-limit \
	--enable-bcmath \
	--enable-shmop \
	--enable-versioning \
	--enable-calendar \
	--enable-dbx \
	--enable-dio \
	--enable-mcal \
in yhe ckecking this is happening

 checking for Sybase-CT support... yes, shared
./configure: line 1: /usr/src/redhat/BUILD/php-4.3.0/ext/sybase_ct/Makefile.in: No such file or directory

after is built the binary, the extension is not loading, this is the apache error log...
[Wed Nov 13 01:03:00 2002] [notice] caught SIGTERM, shutting down
PHP Warning:  Unknown(): Invalid library (maybe not a PHP library) 'sybase_ct.so'  in Unknown on line 0
                             I hope it helps, bye aliet

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-13 19:24 UTC] sniper@php.net
I can not reproduce this with latest CVS (HEAD or PHP_4_3 branch) using this configure line:

./configure --disable-all --disable-cgi --with-sybase-ct=shared,/www/freetds-0.60

Please try this simple configure line.

 [2002-11-14 14:05 UTC] alietss at yahoo dot com
Hi boys, is working with the latest CVS HEAD and Branch of php-4.3.0 and php-4.4.0-dev, of the 20021114.
                                    Bye Aliet
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu May 13 08:01:24 2021 UTC