php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #204 memory_limit does not appear to work.
Submitted: 1998-03-26 21:27 UTC Modified: 1998-04-25 13:35 UTC
From: seb at tach dot com Assigned: jim (profile)
Status: Closed Package: Performance problem
PHP Version: 3.0 Release Cand OS: IRIX 6.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: seb at tach dot com
New email:
PHP Version: OS:

 

 [1998-03-26 21:27 UTC] seb at tach dot com
memory_limit does not appear to work under IRIX6.2.  At
seemingly random intervals, an apache1.3/php process will
start growing without bound (well, until there is no more
and the server crashes).  I get ~50 meg core dumps in my 
html directory, and ~2 meg dumps in my pgsql/data/base/*
directory.  I have also tried decreasing buffers (which
seems to increase the time between core dumps) and setting
max_execution_time.  

Is anyone else successfully using PHP3/Apache/PostgreSQL 
under IRIX6.2?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-04-25 13:35 UTC] zeev
There doesn't appear to be anything wrong with the memory_limit code. Please test it directly
(set the memory_limit to something low and load a script that allocates a bunch of memory in
a while loop).

If you are getting core dumps, please provide backtraces. (Using gdb, you can do this by something
along the lines of "gdb httpd core" and typing "bt" at the prompt.)

The most likely culprit seems to be a leak in the PostgreSQL client code.

Please open another bug (http://ca.php.net/bugs.php3) if it turns out that memory_limit is not broken and
you have information on the real cause. Also include the version of PostgreSQL and Apache you're
using.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 27 18:01:29 2020 UTC