php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20385 After a previous compile error, a new one when installing php4-STABLE-latest.ta
Submitted: 2002-11-12 04:41 UTC Modified: 2002-11-26 19:59 UTC
From: ioana dot radulescu at carbagas dot ch Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 4.3.0-pre2 OS: AIX 4.3.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ioana dot radulescu at carbagas dot ch
New email:
PHP Version: OS:

 

 [2002-11-12 04:41 UTC] ioana dot radulescu at carbagas dot ch
I?ve been trying to install PHP as an Apache module for a week. First I installed Apache the binary version and afterwards I downloaded php-4.2.3.tar.gz. The PHP?s installation worked  well but when trying to configure apache with:
./configure ?activate-module=src/modules/php4/libphp4.a and then run make I received the same error as in the reported bug nr.18001.
Consequently, I have deleted the PHP and Apache old installations and downloaded Apache 1.3.27 and php4-STABLE-latest.tar.gz.
I?ve started again the installation. Everything went well until I ran the PHP?s make install where I received the following error:

bin/sh libtool --silent --mode=link gcc -export-dynamic -O2  -L/usr/local/mysql
/lib  -R /usr/local/mysql/lib ext/ctype/ctype.lo ext/mbstring/mbfilter_ja.lo ext
/mbstring/mbfilter_cn.lo ext/mbstring/mbfilter_tw.lo ext/mbstring/mbfilter_kr.lo
 ext/mbstring/mbfilter_ru.lo ext/mbstring/mbfilter.lo ext/mbstring/mbstring.lo e
xt/mbstring/mbregex.lo ext/mbstring/php_mbregex.lo ext/mbstring/html_entities.lo
 ext/mbstring/php_unicode.lo ext/mysql/php_mysql.lo ext/overload/overload.lo ext
/pcre/pcrelib/maketables.lo ext/pcre/pcrelib/get.lo ext/pcre/pcrelib/study.lo ex
t/pcre/pcrelib/pcre.lo ext/pcre/php_pcre.lo ext/posix/posix.lo ext/session/sessi
on.lo ext/session/mod_files.lo ext/session/mod_mm.lo ext/session/mod_user.lo ext
/standard/array.lo ext/standard/base64.lo ext/standard/basic_functions.lo ext/st
andard/browscap.lo ext/standard/crc32.lo ext/standard/crypt.lo ext/standard/cyr_
convert.lo ext/standard/datetime.lo ext/standard/dir.lo ext/standard/dl.lo ext/s
tandard/dns.lo ext/standard/exec.lo ext/standard/file.lo ext/standard/filestat.l
o ext/standard/flock_compat.lo ext/standard/formatted_print.lo ext/standard/fsoc
k.lo ext/standard/head.lo ext/standard/html.lo ext/standard/image.lo ext/standar
d/info.lo ext/standard/iptc.lo ext/standard/lcg.lo ext/standard/link.lo ext/stan
dard/mail.lo ext/standard/math.lo ext/standard/md5.lo ext/standard/metaphone.lo
ext/standard/microtime.lo ext/standard/pack.lo ext/standard/pageinfo.lo ext/stan
dard/parsedate.lo ext/standard/quot_print.lo ext//standard/rand.lo ext/standard/r
eg.lo ext/standard/soundex.lo ext/standard/string.lo ext/standard/scanf.lo ext/s
tandard/syslog.lo ext/standard/type.lo ext/standard/uniqid.lo ext/standard/url.l
o ext/standard/url_scanner.lo ext/standard/var.lo ext/standard/versioning.lo ext
/standard/assert.lo ext/standard/strnatcmp.lo ext/standard/levenshtein.lo ext/st
andard/incomplete_class.lo ext/standard/url_scanner_ex.lo ext/standard/ftp_fopen
_wrapper.lo ext/standard/http_fopen_wrapper.lo ext/standard/php_fopen_wrapper.lo
 ext/standard/credits.lo ext/standard/css.lo ext/standard/var_unserializer.lo ex
t/standard/ftok.lo ext/standard/aggregation.lo ext/standard/sha1.lo ext/tokenize
r/tokenizer.lo ext/xml/xml.lo ext/xml/expat/xmlparse.lo ext/xml/expat/xmlrole.lo
 ext/xml/expat/xmltok.lo regex/regcomp.lo regex/regexec.lo regex/regerror.lo reg
ex/regfree.lo TSRM/TSRM.lo TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/m
ain.lo main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/safe_mode.lo m
ain/fopen_wrappers.lo main/alloca.lo main/php_ini.lo main/SAPI.lo main/rfc1867.l
o main/php_content_types.lo main/strlcpy.lo main/strlcat.lo main/mergesort.lo ma
in/reentrancy.lo main/php_variables.lo main/php_ticks.lo main/streams.lo main/ne
twork.lo main/php_open_temporary_file.lo main/php_logos.lo main/output.lo main/m
emory_streams.lo main/user_streams.lo Zend/zend_language_parser.lo Zend/zend_lan
guage_scanner.lo Zend/zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/zend_allo
c.lo Zend/zend_compile.lo Zend/zend_constants.lo Zend/zend_dynamic_array.lo Zend
/zend_execute_API.lo Zend/zend_highlight.lo Zend/zend_llist.lo Zend//zend_opcode.
lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo Zend/zend_va
riables.lo Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.
lo Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zen
d_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zen
d_execute.lo sapi/cli/php_cli.lo sapi/cli/getopt.lo main/internal_functions_cli.
lo -lmysqlclient -lcrypt -lm -lcrypt  -o sapi/cli/php
ld: 0711-161 ERROR: File ext/ctype/ctype.lo cannot be processed.
        The file was found to be truncated and is being ignored.
collect2: ld returned 8 exit status
make: *** [sapi/cli/php] Error 1


What can I do in order  to install finally this software on a RS6000 machine with OS AIX 4.3.3
Any help would be appreciated. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-12 09:29 UTC] iliaa@php.net
I've seen the same error compiling on SunOS. The solution to the problem was to do a 'make clean' and then recompile the sources.
 [2002-11-26 19:59 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jun 13 07:01:34 2024 UTC