php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20364 Fatal error: Cannot instantiate non-existent class: java in file on line
Submitted: 2002-11-11 09:31 UTC Modified: 2002-11-11 09:49 UTC
From: andi at rc dot austria dot hp dot com Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.2.3 OS: HP-UX 11.11
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: andi at rc dot austria dot hp dot com
New email:
PHP Version: OS:

 

 [2002-11-11 09:31 UTC] andi at rc dot austria dot hp dot com
Hello everybody,

i allready checked Bug #16770 it seems to be the same issue. I followed the provided solution but still got the same error message:\
Invoking Java...
Fatal error: Cannot instantiate non-existent class: java in /opt/apache-1.3.27/htdocs/testjava.php on line 5
First i was using php 4.2.2 after reading the conclusion of bug 16770 i upgraded to 4.2.3 but got the same error message.
#######################
My environment:
HP-UX 11.11
HP-UX C compiler
java j2sdk1.4. (provided by hp.com/go/java)
php 4.2.3
zlib-1.1.4
#######################
testfile:
more /opt/apache-1.3.27/htdocs/testjava.php
<?php

print "Invoking Java...";

$systemInfo = new Java("java.lang.System");

print "Java initialized.";

print "Total seconds since January 1, 1970:
".$systemInfo->currentTimeMillis();

?>
#######################
php.ini:
[Java]
java.class.path = /opt/php-4.2.3/lib/php/php_java.jar/php_java.jar
java.home = /opt/java1.4
java.library = /opt/java1.4/jre/lib/PA_RISC/libjava.sl
java.library.path = /opt/java1.4/jre/lib/PA_RISC
extension_dir=/usr/local/lib/php/extensions/no-debug-non-zts-2002042
extension=java.a
#######################
php config:
./configure --prefix=/opt/php-4.2.3 --with-zlib=/opt/zlib-1.1.4 --enable-mbstring --enable-mbregex --enable-cli -
-with-java=/opt/java1.4 --without-mysql --without-libmysql --with-apache=/opt/apache_1.3.27
#######################
apache config:
./configure --prefix=/opt/apache-1.3.27 --add-module=./src/modules/standard/mod_vhost_alias.c --add-module=./src/
modules/standard/mod_env.c --add-module=./src/modules/standard/mod_log_config.c --add-module=./src/modules/standa
rd/mod_mime_magic.c --add-module=./src/modules/standard/mod_negotiation.c --add-module=./src/modules/standard/mod
_status.c --add-module=./src/modules/standard/mod_info.c --add-module=./src/modules/standard/mod_include.c --add-
module=./src/modules/standard/mod_autoindex.c --add-module=./src/modules/standard/mod_dir.c --add-module=./src/mo
dules/standard/mod_cgi.c --add-module=./src/modules/standard/mod_asis.c --add-module=./src/modules/standard/mod_i
map.c --add-module=./src/modules/standard/mod_actions.c --add-module=./src/modules/standard/mod_speling.c --add-m
odule=./src/modules/standard/mod_userdir.c --add-module=./src/modules/standard/mod_alias.c --add-module=./src/mod
ules/standard/mod_access.c --add-module=./src/modules/standard/mod_auth.c --add-module=./src/modules/standard/mod
_auth_anon.c --add-module=./src/modules/standard/mod_auth_dbm.c --add-module=./src/modules/standard/mod_digest.c
--add-module=./src/modules/standard/mod_cern_meta.c --add-module=./src/modules/standard/mod_expires.c --add-modul
e=./src/modules/standard/mod_headers.c --add-module=./src/modules/standard/mod_usertrack.c --add-module=./src/mod
ules/standard/mod_unique_id.c --add-module=./src/modules/standard/mod_setenvif.c --activate-module=src/modules/ph
p4/libphp4.a

Thanks in advance for your support,
Andi Monari

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-11 09:49 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in PHP.
 [2002-11-11 10:11 UTC] andi at rc dot austria dot hp dot com
Sorry for the wrong entry.
I added some comments to the propper case.

Please ignore/reset/delete this issue.

Thanks,
Andi
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 09:01:28 2024 UTC