php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20325 Pear package creates an archive with package.xml only
Submitted: 2002-11-09 03:40 UTC Modified: 2002-11-20 07:01 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: arnaud dot limbourg at club-internet dot fr Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.3.0-pre2 OS: redhat 7.3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: arnaud dot limbourg at club-internet dot fr
New email:
PHP Version: OS:

 

 [2002-11-09 03:40 UTC] arnaud dot limbourg at club-internet dot fr
When using the pear package command it creates an archive with just package.xml in it.

Ex:
 tar -tzf Net_URL-1.0.4.tgz 
package.xml

It does that with any package.

Pear is 1.0b1

Arnaud.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-09 06:39 UTC] nicos@php.net
I think we can consider that as a duplicate of mine, lets fix "pear package" and both will be fixed.
 [2002-11-10 13:56 UTC] dickmann@php.net
I don't think that these two problems are related.

BTW: The package contains all files and the pear installer is able to access all of them at my box. Only standalone tar has problems with it ...
 [2002-11-13 01:38 UTC] mansion@php.net
Same bug on Darwin.
So it's not a Linux or Darwin related bug, looks like it is 
more Archive_Tar related...
 [2002-11-20 05:39 UTC] mansion@php.net
This seems to be fixed in the latest 1.0b1.
I was using RC1 before. BTW, it's a pain to upgrade from 
RC1 to 1.0b1.
 [2002-11-20 07:01 UTC] arnaud dot limbourg at club-internet dot fr
As i said I am using 1.0b1
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 09:03:35 2021 UTC