php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20321 pear package problem
Submitted: 2002-11-08 19:39 UTC Modified: 2002-11-22 06:12 UTC
From: nicos@php.net Assigned:
Status: Closed Package: PEAR related
PHP Version: 4CVS-2002-11-08 OS: Linux 2.4.19
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nicos@php.net
New email:
PHP Version: OS:

 

 [2002-11-08 19:39 UTC] nicos@php.net
I have been trying to create my own package with my package.xml. I see nothing wrong and I keep get the same error with ANY package of pear/

Example:
[Sat Nov  9 - 02:35:49 - root ~/pear/Net_Ping]# pear package package.xml

Warning: chdir() [http://www.php.net/function.chdir]: No such file or directory (errno 2) in /usr/local/lib/php/PEAR/Packager.php on line 174
tar: Cowardly refusing to create an empty archive
Try `tar --help' for more information.
package ok
[Sat Nov  9 - 02:35:54 - root ~/pear/Net_Ping]#

[Sat Nov  9 - 02:37:18 - root ~/pear/PECL/spplus]# pear package package.xml

Warning: chdir() [http://www.php.net/function.chdir]: No such file or directory (errno 2) in /usr/local/lib/php/PEAR/Packager.php on line 174
tar: Cowardly refusing to create an empty archive
Try `tar --help' for more information.
package ok
[Sat Nov  9 - 02:37:19 - root ~/pear/PECL/spplus]#

I really think that first, Packager.php should have some verifications before saying its ok and trying to use function without verifying what argument it got.

Anyway Packager.php looks totally broken.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-09 03:28 UTC] arnaud dot limbourg at club-internet dot fr
With 
| PEAR           | 1.0b1   | stable |

I get the following for Net-Ping

 pear package package.xml
Error: missing description
Error: missing license
Validation: 2 error(s), 0 warning(s)
Fix these errors and try again.

 pear package package.xml 
Package /home/arnaud/development/pear/PECL/spplus/spplus-1.0.tgz done
Tag the released code with `pear cvstag package.xml'
(or set the CVS tag RELEASE_1_0 by hand)


The problem is that it creates an archive with just package.xml in it. This problem has been reported.

I could not reproduce your bug. What platform are you running ?

Arnaud.
 [2002-11-09 06:41 UTC] nicos@php.net
This was on a linux box, redhat I think.Anyway Net_Ping is an old package and is supposed to work...
 [2002-11-09 10:11 UTC] mj@php.net
Could you please run

lynx -source http://go-pear.org | php

in order to install the latest version of the PEAR package manager. I'm unable to reproduce the problem with this version.
 [2002-11-21 17:13 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2002-11-22 06:12 UTC] nicos@php.net
Fixed.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 20 16:03:42 2021 UTC