php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20316 Apache error loading PHP
Submitted: 2002-11-08 12:16 UTC Modified: 2002-11-08 12:19 UTC
From: jmr1 at vianet dot ca Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.3 OS: Win 98 SE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jmr1 at vianet dot ca
New email:
PHP Version: OS:

 

 [2002-11-08 12:16 UTC] jmr1 at vianet dot ca
I am getting an error launching apache 2.0.43 with the php 4.2.3 module (not the CGI). I have Win98SE

My command is this:
Apache.exe -w -f "C:\Apache\Apache2\conf\httpd.conf" -d "C:\Apache\Apache2\."

The error is this:
Syntax error on line 978 of C:/Apache/Apache2/conf/httpd.conf:
Cannot load F:/php/sapi/php4apache.dll into server: One of the library files
needed to run this application cannot be found.

Line 978 and on reads:
LoadModule php4_module "f:/php/sapi/php4apache.dll"
AddType application/x-httpd-php .php .php3 .phtml
AddType application/x-httpd-php-source .phps

I have php4ts.dll in both the system and system32 directories (just in case). I tried backslashes instead which lets apache load but php won't work.

I tried copying everything to my c: drive and updating the LoadModule line to point to C instead of F. Same error.

I tried the LoadModule line without quotes: Same error.

There are currently 2 php4apache.dll files on my pc:
C:\php\sapi\php4apache.dll and F:\php\sapi\php4apache.dll

There are no sapi directories under the apache directory.
apache only has mod_isapi files.

I read on Mr Jacob's site that I should have put php2apache2.dll instead.
Upon trying this, I received the following error:

APACHE.EXE: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" is not
compatible with this version of Apache (found 20020628, need 20020903).
Please contact the vendor for the correct version.

Thanks

John

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-08 12:17 UTC] derick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in PHP.
 [2002-11-08 12:19 UTC] jmr1 at vianet dot ca
I did not have apache nor php installed before loading apache 2.0.43 and php 4.2.3.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 21:01:30 2024 UTC