php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20311 Apachechild ends with Memory-Read-Error if using session.serialize_handler=wddx
Submitted: 2002-11-08 08:11 UTC Modified: 2003-07-21 09:17 UTC
From: mike at iworks dot at Assigned:
Status: Closed Package: WDDX related
PHP Version: 4.3.2 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mike at iworks dot at
New email:
PHP Version: OS:

 

 [2002-11-08 08:11 UTC] mike at iworks dot at
If your php.ini is set up like

session.serialize_handler = wddx

Apache's Child gets terminated and exits with an Memory-Read Error if you want to start a session.

(Log: [notice] Parent: child process exited with status 3221225477 -- Restarting.)

Everything else is fine... except BUG#19122 is still there, too.

Configuration:
- Win 2000 SP2
- Apache 2.0.43
- PHP 4.2.3 (Apache 2 Filter DLL)

Bye,
Michael

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-08 08:51 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip
 [2002-11-11 06:15 UTC] m dot DOT dot wallnet at iworks dot DOT dot at
No changes with this version:

Downloaded 11/11/2002

PHP-4.3.0-dev
System: Windows NT localhost 5.0 build 2195 
Build Date: Nov 11 2002 12:13:03 
Server API: Apache 2.0 Filter 
PHP API 20020918
PHP Extension 20020429
Zend Extension 20021010

I used the link above to download the Win32-binaries.

Michael
 [2002-11-11 09:46 UTC] m dot DOT dot wallner at iworks dot DOT dot at
Status changed to OPEN.
I think that's right, isn't it?

If you call phpinfo() there's one little line not there where it should be:

Section WDDX
WDDX Support: enabled
WDDX Session Serializer (this line is missing)

Michael
 [2002-12-19 23:09 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-12-29 06:30 UTC] m dot DOT dot wallner at iworks dot DOT dot at
No changes in 4.3.0 Final.
I'll try a snap soon.

Bye,
Michael
 [2003-04-02 17:25 UTC] jpenn at cheetah-soft dot com
Still not working in 4.3.1 - Apache is still terminating when a call to session_start() is made when using 'wddx' as the serialize handler. Both win 2000 and red hat 7...
 [2003-07-10 21:37 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

I can't reproduce this..

 [2003-07-18 18:47 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-07-21 09:04 UTC] m dot DOT dot wallner at iworks dot DOT dot at
Works fine now with PHP 4.3.2 (on RH9)

Michael
 [2003-07-21 09:17 UTC] mike at iworks dot at
But still not with PHP 4.3.2 on Win2k...

I'll try a snap whem i find time to...

Michael
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu May 30 07:01:30 2024 UTC