php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20275 Zlib problem
Submitted: 2002-11-06 03:15 UTC Modified: 2002-11-07 17:29 UTC
From: michal at vrabel dot cz Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 4CVS-2002-11-06 OS: Redhat 7.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michal at vrabel dot cz
New email:
PHP Version: OS:

 

 [2002-11-06 03:15 UTC] michal at vrabel dot cz
Hello.

I have installed newest STABLE PHP4 and Apache 2.0.40.

I have this problem with Zlib version 1.0.3 which is included in PHP4 STABLE.

I am using IE 5.5 at Win2k Prof.

When i am try open some gzipped page (.php script) i get unreadable code (packed code). But only at some pages. Not at all pages. I am reinstall system and everything is the same. I am not behind the proxy. Can you tell me, if Zlib 1.0.3 have some bug?
When i have Apache 1.2.26 and PHP 4.1.2 everything was good.
I am dont using global compress. I am active compress in php script by this lines:

if (strstr($HTTP_USER_AGENT,'compatible') ) {
 if (extension_loaded('zlib') ) {
   ob_start('ob_gzhandler');
 }
}

Thank you.

Michal Vrabel.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-06 08:29 UTC] iliaa@php.net
zlib 1.0.3 is fairly old, considering that the current version is 1.1.4. Upgrade will definately solve @least 1 security vunreability in zlib and very well may resolve the problem with page compression you are seeing with PHP.
 [2002-11-06 12:48 UTC] michal at vrabel dot cz
Hi.

Sorry. I wrote bad version. I means zlib 1.1.3 which still do that problem. How can i install zlib 1.1.4. When i compile zlib source distribution, zlib.so was not compiled. only zlib.a


Thank you.
 [2002-11-06 12:55 UTC] iliaa@php.net
You can make libz.so (shared zlib library) by adding -shared flag to the compile line. However, 1.1.3 is fairly recent, so it should be ok to use (that's what I have). Have you tried to verify this bug in other browsers such as Mozilla, IE 6.0, Opera? It may be that you've come across a quirck in your installation of IE 5.5
 [2002-11-06 13:03 UTC] michal at vrabel dot cz
Hello.

I tryed this:

Reinstal PC with Windows 2000 Prof, which includes IE 5.0. In IE 5.0 was the same problem. Then i install SP3 for W2K, IE 5.5 and the problem was still. My friend with IE 5.x(??) try it too, but he have the same problem with page, which i cannot open too.
I try open that pages at Netscape 7.0 and everything was ok... But when i had Apache 1.2.x and PHP 4.1.2 i have no problem. Problem is now, when i uses Apache 2 and PHP 4.3.0-dev.

Thankx.
 [2002-11-06 13:25 UTC] michal at vrabel dot cz
Now I compile zlib 1.1.4 and PHP latest STABLE and phpinfo() says that i have Compiled version 1.1.4 and linked version 1.1.3.

In ./configure of php i wrote ..... --with-zlib --with-zlib-dir=/usr

zlib i compile ./configure --prefix=/usr -shared

Zlib.so has been compiled but i dont know why PHP writes that linked version is 1.1.3. What i have to do to have Linked version 1.1.4? 

Thankx.

Michal Vrabel.
 [2002-11-07 17:29 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 06:01:23 2020 UTC