php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20263 CURL: feof doesn't work with --with-curlwrappers
Submitted: 2002-11-05 10:09 UTC Modified: 2014-04-25 09:43 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: kjartan at zind dot net Assigned:
Status: Wont fix Package: cURL related
PHP Version: 5CVS OS: Linux RH 7
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: kjartan at zind dot net
New email:
PHP Version: OS:

 

 [2002-11-05 10:09 UTC] kjartan at zind dot net
The following script works fine without curlwrappers, but the while loop never exits with it enabled:

<?php
print "Opening site..\n";
if ($fp = fopen('http://www.cnn.com/', 'r')) {
  print "Reading data..\n";
  while (!feof($fp)) {
    $data .= fgets($fp, 128);
  }
  print "closing file..\n";
  fclose($fp);
  print $data;
}
?>

./configure --with-mysql=/usr/local/ --with-apxs --sysconfdir--mandir=/usr/local/man/ --enable-calendar --enable-ftp --with-openssl --without-pear --with-curl=/usr/lib --with-zlib --enable-tokenizer --with-imap-ssl --with-gd --with-curlwrappers --disable-mbstring

curl 7.10.1 (i686-pc-linux-gnu) libcurl/7.10.1 OpenSSL/0.9.6d zlib/1.1.3

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-05 10:51 UTC] kjartan at zind dot net
The option is present in 4.3.0pre2 with no mention of the curlwrappers being experimental. If it is known this will not work for 4.3 wouldn't it make sense to remove the configure option from ./configure --help until it works?
 [2002-11-06 03:56 UTC] wez@php.net
That was the plan.
Suspending this for now.
Thanks for being eager to try this out; we're really
waiting for features in the curl library (otherwise
it would be in PHP 4.3).
 [2003-01-15 05:56 UTC] daniel at haxx dot se
Don't wait. Act!

Since I am the single person who develop libcurl on a regular basis, I can assure you that I don't know what features you're missing and that I am not likely to add them without being pushed in the right direction, most preferably with some hands-on help.
 [2003-11-29 01:50 UTC] sniper@php.net
Wez, maybe you should tell Daniel what you need for this to work..? :)

 [2004-04-22 02:05 UTC] wez@php.net
Sorry Daniel, but I don't even use curl these days.
 [2004-09-16 14:50 UTC] wez@php.net
Please stop assigning this bug to me
 [2010-12-03 18:13 UTC] jani@php.net
-Package: Feature/Change Request +Package: cURL related
 [2014-04-25 09:43 UTC] mike@php.net
-Status: Open +Status: Wont fix -Type: Feature/Change Request +Type: Bug
 [2014-04-25 09:43 UTC] mike@php.net
curlwrappers have been removed in PHP-5.5
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 15:01:25 2019 UTC