php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20228 Make fails when compiling with GD
Submitted: 2002-11-03 08:05 UTC Modified: 2002-11-03 08:31 UTC
From: aceonline at yahoo dot com Assigned:
Status: Closed Package: GD related
PHP Version: 4.2.3 OS: Linux Redhat 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aceonline at yahoo dot com
New email:
PHP Version: OS:

 

 [2002-11-03 08:05 UTC] aceonline at yahoo dot com
I looked through the already submitted bugs and some might have been similar, but none had the same error. 

I have compiled and installed GD version 2.0.4. This is on a fresh installation of linux, so there shouldn't be any older versions of GD that might be lying around. My PHP configure statement is as follows:

./configure --with-mysql=/usr/local/mysql --with-xml --with-zlib --with-gd=/usr --with-jpeg-dir=/usr/include --with-png-dir=/usr/include --with-xpm-dir=/usr/include --enable-ftp --enable-trans-sid --enable-track-vars --with-apache=../apache_1.3.27

PHP then configures correctly, but when performing the make command for PHP, I get the following error:

In file included from gd.c:83:
gd_ctx.c: In function `_php_image_output_ctx':
gd_ctx.c:70: structure has no member named `free'
gd_ctx.c:98: structure has no member named `free'
gd.c: In function `_php_image_type':
gd.c:1014: structure has no member named `free'
gd.c:1017: structure has no member named `free'
gd.c: In function `_php_image_create_from':
gd.c:1209: structure has no member named `free'
make[3]: *** [gd.lo] Error 1
make[3]: Leaving directory `/root/downloads/php-4.2.3/ext/gd'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/downloads/php-4.2.3/ext/gd'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/downloads/php-4.2.3/ext'
make: *** [all-recursive] Error 1
[root@lighthouse php-4.2.3]# locate gd.h
/root/downloads/gd-2.0.4/gd.h
/root/downloads/php-4.2.3/ext/gd/php_gd.h
/usr/include/gd.h

If the solution to this problem is to use an older version of GD, what is the command to uninstall GD? I tried "make uninstall", but that did not work. I can't find it anywhere in the GD docs either.

Thanks in advance,
Ace


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-03 08:31 UTC] sander@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.
 [2002-12-15 16:07 UTC] phpbug at spambox dot dk
If this is fixed in CVS, why is this bug still in 4.3.0RC3?

Best regards Henrik
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 23:05:54 2022 UTC