php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20201 wont start (LoadModule issue)
Submitted: 2002-10-31 14:07 UTC Modified: 2004-08-18 17:41 UTC
From: Boris at CrazySnowBoarder dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.3.0-pre2 OS: xp home
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Boris at CrazySnowBoarder dot com
New email:
PHP Version: OS:

 

 [2002-10-31 14:07 UTC] Boris at CrazySnowBoarder dot com
ok i have php 4.3.0-pre2 on the apache2 2.0.43 on winXP(sp1) Home... it doesn't start...

i have following lines in httpd.conf
LoadModule php4_module C:\Program Files\PHP\SAPI\php4apache2.dll
AddType application/x-httpd-php .php

i have both php4ts.dll and php4sapi.dll in c:\windows\system32...

and it doesn't run...

thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-31 14:08 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-10-31 14:34 UTC] Boris at CrazySnowBoarder dot com
ok problme is with this line
LoadModule php4_module C:\Program Files\PHP\SAPI\php4apache2.dll

i have tried many combination and moved file to differnt 
loaction including root of apache2...

as soon as i add this line to(httpd.conf) apache doesn't start....

when i run command apache.exe -k start
it gives me that loadModule requres 2 argumes and i have too..
 [2002-10-31 14:35 UTC] derick@php.net
Don't use a space in your directory name, this is the argument seperator. Putting "" around the path _might_ work.
Not a bug -> bogus
 [2002-10-31 14:54 UTC] Boris at CrazySnowBoarder dot com
ok then i get this...

apache: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" is not comp
atible with this version of Apache (found 20020628, need 20020903).
Please contact the vendor for the correct version.
 [2002-10-31 14:58 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Not a bug, the versions dont match. Get the latest snapshot off snaps.php.net (http://snaps.php.net/php4-latest.tar.gz)
 [2004-08-18 17:41 UTC] Boris at CrazySnowBoarder dot com
Works fine in later Versions with right configuration
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 00:01:29 2024 UTC