php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20114 Post looses first 4 characters
Submitted: 2002-10-26 23:39 UTC Modified: 2002-11-14 01:48 UTC
Votes:8
Avg. Score:4.8 ± 0.7
Reproduced:8 of 8 (100.0%)
Same Version:6 (75.0%)
Same OS:4 (50.0%)
From: admin at modernbill dot com Assigned:
Status: Closed Package: mbstring related
PHP Version: 4.2.3 OS: Red Hat Linux release 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: admin at modernbill dot com
New email:
PHP Version: OS:

 

 [2002-10-26 23:39 UTC] admin at modernbill dot com
Posting to an array variable LOOSES the first 4 charcters of data every time.

The best way to see this is by example:

<!-- INPUT -->
<form action="<?=$_SELF?>" method="POST">
<input name="variable[]" value="123456789">
<input name="variable[]" value="abcdefghi">
<input type=submit value=submit name=submit>
</form>
<pre>
<?=print_r($_POST);?>
</pre>

<!-- OUTPUT -->
Array
(
    [variable] => Array
        (
            [0] => 56789
            [1] => efghi
        )

    [submit] => submit
)

---

I noticed this bug after a few clients upgraded to PHP 4.2.3 from 4.2.2. Nothing else changed on the server.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-27 00:45 UTC] moriyoshi@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

Also try --disable-mbstr-enc-trans if you still want to use 4.2.3.
 [2002-10-27 11:04 UTC] nstrunc at nslink dot net
I upgraded to the lastest snapshot and it works great. I think this is also a problem in 4.3.0pre1 because I tried to upgrade to that and it still didn't work.
 [2002-10-28 15:14 UTC] moriyoshi@php.net
Thank you for the report.
There is no difference between 4.3.0-pre1 and CVS HEAD version in the part of code blamed in 4.2.3, so I don't see the problem there.
Did you get the same result with pre1 version?
 [2002-10-29 16:16 UTC] dan at ohnesorg dot cz
I have also the same problem. OS is SuSE 8.0, 4.2.3 
version of php compiled by myself.
 [2002-10-30 12:12 UTC] moriyoshi@php.net
Hello, Dan
Did you try the latest snapshot at http://snaps.php.net/ ?

 [2002-11-14 01:48 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 23:03:13 2021 UTC