php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2006 Memory leaks?
Submitted: 1999-08-09 12:26 UTC Modified: 1999-08-23 15:04 UTC
From: georgeh at blowtorch dot com Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0 Latest CVS (09/08/1999) OS: Stock Redhat 6.0 / ECommerce Edi
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: georgeh at blowtorch dot com
New email:
PHP Version: OS:

 

 [1999-08-09 12:26 UTC] georgeh at blowtorch dot com
I'm submitting this FWIW. It may be a known problem or not a problem at all. Just something I noticed in my logs:

/usr/local/bps/htdocs/ris/htdocs/services.phtml:  Freeing 0x081E4D30 (4 bytes), allocated in zend_hash.c on line 185<br>
/usr/local/bps/htdocs/ris/htdocs/services.phtml:  Last leak repeated 1 time
/usr/local/bps/htdocs/ris/htdocs/services.phtml:  Freeing 0x08207D90 (44 bytes), allocated in zend_hash.c on line 175<br>
/usr/local/bps/htdocs/ris/htdocs/services.phtml:  Last leak repeated 3 times
/usr/local/bps/htdocs/ris/htdocs/professional.phtml:  Freeing 0x081CA138 (4 bytes), allocated in zend_hash.c on line 185<br>
/usr/local/bps/htdocs/ris/htdocs/professional.phtml:  Last leak repeated 1 time
/usr/local/bps/htdocs/ris/htdocs/professional.phtml:  Freeing 0x081DD5D8 (44 bytes), allocated in zend_hash.c on line 175<br>
/usr/local/bps/htdocs/ris/htdocs/professional.phtml:  Last leak repeated 3 times

Here's my configure line (although this looks like a zend issue:)

# ./configure  --with-apxs=/usr/sbin/apxs --with-mysql=/usr --with-dbase=yes --with-filepro=yes --with-zlib --enable-sysvshm=yes --enable-sysvsem=yes --enable-magic-quotes=yes


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-08-23 15:04 UTC] andi at cvs dot php dot net
Please check if this still happens with the latest CVS.
If it does then try and cut down your scripts to the smallest script possible that reproduces this.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Nov 12 07:01:37 2019 UTC