php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20034 Webserver hangs on certain conditions
Submitted: 2002-10-22 19:15 UTC Modified: 2002-11-10 18:25 UTC
From: alejandro dot garza at itesm dot mx Assigned:
Status: Closed Package: iPlanet related
PHP Version: 4.2.3 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alejandro dot garza at itesm dot mx
New email:
PHP Version: OS:

 

 [2002-10-22 19:15 UTC] alejandro dot garza at itesm dot mx
I have been testing PHP as a nsapi plugin with IPlanet 4.1 no Solaris 8 with this configuration:
  export CC; CC=gcc ; ./configure --with-mysql=/usr/local/www/biblio/dev/mysql --with-nsapi
=/opt/iplanet/webserver --enable-libgcc

PHP scripts work fine, however upons certain (unknown?) conditions, the Iplanet server stops responding. The access logs show no more responses, the Iplanet error log shows nothing. 

This usualy happens when there is more load upon the server. The last lines in the access log before the server lockup are for normal pages, like GIFs, HTML, etc. -- not even PHP scripts.

I have had this happen within a few minutes of restarting the server, or within a few hours. When I remove links to the frequently-called scripts and replace them back to their old CGI (bleah!) counterparts, the server keeps on going with no problem.

This is a high-traffic server, so this is frustrating.
Does this have anything to do with thread safety? Does anyone have stability issues with IPlanet?

I tried PHP 4.1.2 before installing 4.2.3, with the same results.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-22 19:23 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip
 [2002-10-23 10:33 UTC] alejandro dot garza at itesm dot mx
Downloaded latest CVS, tried with same configure line, got compile error:

/bin/sh libtool --silent --mode=compile gcc  -Iext/standard/ -I/usr/local/www/biblio/dev/php4-200210221500/ext/standard/ -DPHP_ATOM_INC -I/usr/local/www/biblio/dev/php4-200210221500/include -I/usr/local/www/biblio/dev/php4-200210221500/main -I/usr/local/www/biblio/dev/php4-200210221500 -I/opt/iplanet/webserver/plugins/include -I/usr/local/www/biblio/dev/php4-200210221500/Zend -I/usr/local/www/biblio/dev/mysql/include/mysql -I/usr/local/www/biblio/dev/php4-200210221500/ext/xml/expat  -D_POSIX_PTHREAD_SEMANTICS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -I/usr/local/www/biblio/dev/php4-200210221500/TSRM  -g -O2 -pthreads -DZTS  -prefer-pic -c /usr/local/www/biblio/dev/php4-200210221500/ext/standard/basic_functions.c -o ext/standard/basic_functions.lo 
/usr/local/www/biblio/dev/php4-200210221500/ext/standard/basic_functions.c:77: getopt.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ext/standard/basic_functions.lo'

I will try to find bugreport on this issue to fix and test...
 [2002-10-24 02:26 UTC] sniper@php.net
Please try newer snapshot as that compile error should be fixed now.

 [2002-10-24 11:37 UTC] alejandro dot garza at itesm dot mx
Nope, still getting same error for snapshot php4-200210240900 ...
 [2002-10-24 13:13 UTC] sniper@php.net
Please follow the status on this bug:

http://bugs.php.net/?id=20063&edit=1

And when that is fixed, try a new snapshot.

 [2002-11-10 18:25 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 [2002-11-22 10:38 UTC] gduwelz-rebert dot cs at clearstream dot com
Hi,

we have exactly the same problem with php 4.2.1 on solaris 2.6 with iplanet4
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat May 25 21:01:29 2024 UTC